Opened 10 years ago

Closed 10 years ago

Last modified 13 months ago

#4492 closed defect (fixed)

WINCE: Aspect Ratio Correction Bug

Reported by: SF/pncfreak Owned by: SF/knakos
Priority: normal Component: Port: WinCE
Keywords: Cc:
Game:

Description

Bug found whilst testing static build from 07.28.2009 on Touch Pro2 (WM 6.1):

Using 'Aspect Ratio Correction' produces vertical mouse cursor off-set when rotated 180 degrees in landscape mode in 480x800 devices.

Everything works fine when the default landscape mode initiates, mouse cursor is aligned with screen touch point, both when using toolbar and in full-screen.

When rotating landscape mode 180 degrees, everything is fine with toolbar present, but when the toolbar is removed the mouse cursor is off-set vertically with approx. the height of the toolbar.
I.e. clicking on the screen moves the mouse cursor to a point far below the clicking-point.

Kostas thinks this is caused by the absence of an 'aspect2real/real2aspect call' somewhere.

(The reason why I always rotate the default landscape orientation is that I wish to play with the phone HW keyboard slided out and the screen tilted into upright position.)

Ticket imported from: #2829001. Ticket imported from: bugs/4492.

Change History (4)

comment:1 by fingolfin, 10 years ago

Owner: set to SF/knakos
Summary: PocketPC/WinCE: Aspect Ratio Correction BugWINCE: Aspect Ratio Correction Bug

comment:2 by SF/knakos, 10 years ago

Resolution: fixed
Status: newclosed

comment:3 by SF/knakos, 10 years ago

Fixed, by way of cleaning up Robin's patch a bit.

Thanks for the report.

comment:4 by digitall, 13 months ago

Component: Port: WinCE
Note: See TracTickets for help on using tickets.