Opened 10 years ago

Closed 10 years ago

Last modified 12 months ago

#4407 closed defect (fixed)

WINCE: problem in landscape mode on WQVGA devices

Reported by: SF/mak1 Owned by: SF/knakos
Priority: normal Component: Port: WinCE
Keywords: Cc:
Game:

Description

The problem is that after switching to landsape mode on my i900 Omnia (WQVGA device: 240x400) the horizontal gap between the cursor cross and the place which I tap is appeared (like a bad calibration). You can reproduce the problem using the Microsoft Windows Mobile Device Emulator if you set that resolution.

Step to reproduce:
1. Run the game "Indiana Jones and the Fate of Atlantis" in portrait mode.
2. Tap the icon to switch to the landscape mode (you should tap it only once: if you tap it twice the program is switched to the other-hand landscape mode which does not have the problem).
3. Try to tap on any game object.

I suspect that it is a bug in the algorithm with determines the horizontal position of the cursor cross: 320 is used instead of the real screen width (400).

Ticket imported from: #2821082. Ticket imported from: bugs/4407.

Change History (9)

comment:1 by fingolfin, 10 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by fingolfin, 10 years ago

Owner: set to SF/knakos
Summary: The problem in landscape mode on WQVGA devicesWINCE: problem in landscape mode on WQVGA devices

comment:3 by SF/mak1, 10 years ago

ScummVM version: 0.13.1 (WinCE)
Bug details: see the details
Language of game: English
Version of game: floppy I think
Platform and Compiler: WinCE
Attach a save game if possible: not necessary to reproduce

comment:4 by SF/robinwatts, 10 years ago

I believe this is caused by a problem in our version of the SDL library. I put together a patch for this the other day, and I believe the versions online have been updated. When we get a new wince build online this should be fixed.

In the meantime, I have a version at http://www.wss.co.uk/scummvm/pncfreak that you can test - this only contains the scumm engine, but that should be enough to test Atlantis on.

Please let us know if this fixes the problem.

Robin

comment:5 by SF/mak1, 10 years ago

I've test the build. You solved the problem,
Thank you.

comment:6 by SF/knakos, 10 years ago

Thanks to both of you. Closing.

comment:7 by SF/knakos, 10 years ago

Resolution: fixed
Status: newclosed

comment:8 by Strangerke, 6 years ago

Component: --Unset--Ports

comment:9 by digitall, 12 months ago

Component: PortsPort: WinCE
Note: See TracTickets for help on using tickets.