Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4380 closed defect (fixed)

BASS: "showgrid" enabled triggers an assert

Reported by: SF/jmmdebian Owned by: joostp
Priority: high Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

Running command `showgrid` in the debugger at the very end of the subway
tunnel and then going into the next room causes the program to abort due to an assertion failure:

Reported in the Debian BTS with a save game and the necessary steps to reproduce:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=462618

This can still be reproduced with 0.13.1.

Ticket imported from: #2813472. Ticket imported from: bugs/4380.

Attachments (1)

sky_grid.patch (1.2 KB) - added by peres 10 years ago.
Patch for bug #2813472

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by sev-

Raising priority. This bug is nice to get fixed before the release.

comment:2 Changed 10 years ago by sev-

Priority: normalhigh

Changed 10 years ago by peres

Attachment: sky_grid.patch added

Patch for bug #2813472

comment:3 Changed 10 years ago by peres

I am posting a patching instead of committing to trunk since I am not familiar with the sky engine.

The patch just disables the display of the grid for locations which don't have one. Somebody please review and commit the patch if adequate.

comment:4 Changed 10 years ago by sev-

Owner: set to joostp

comment:5 Changed 10 years ago by sev-

Joost, could you take a look into it?

comment:6 Changed 10 years ago by fingolfin

Summary: Running BASS with "showgrid" enabled triggers an assertBASS: "showgrid" enabled triggers an assert

comment:7 Changed 10 years ago by joostp

Thanks peres, this fix looks fine to me.

comment:8 Changed 10 years ago by joostp

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.