Opened 10 years ago

Closed 10 years ago

#4381 closed defect (invalid)

DW2: Segfault when using Surfboard

Reported by: SF/upwhatever Owned by: dreammaster
Priority: normal Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld II

Description

I got ScummVM 0.14.0svn41929 (current version, compiled 15min ago) and the german CD-Version of Discworld2.
When I try to use the Surfboard on the Water in Act2, the surfing animation beginns, but after ~1sec ScummVM segfaults.

OS is Ubuntu 9.04 x86 with running on my old athlon xp. Makefile was created with "./configure --enable-tinsel --enable-sci", compiler is gcc 4.3.3 (ubuntu's default).

Savegame attached.

Ticket imported from: #2813639. Ticket imported from: bugs/4381.

Attachments (2)

dw2-de.005 (2.6 KB ) - added by SF/upwhatever 10 years ago.
Savegame on beach; use board from chest on water.
dw2-de.affected.md5.txt (12.0 KB ) - added by SF/upwhatever 10 years ago.
md5sum of my dw2 files

Download all attachments as: .zip

Change History (7)

by SF/upwhatever, 10 years ago

Attachment: dw2-de.005 added

Savegame on beach; use board from chest on water.

comment:1 by jvprat, 10 years ago

Owner: set to dreammaster

comment:2 by dreammaster, 10 years ago

I just tried the savegame locally with my English version on WIndows XP (MSVC8 compiled), and didn't get any errors. I'm going to throw this bug report open again - maybe if someone else with either the German version and/or a Ubuntu/x86 system can see whether the error occurs.

I'd also recommend, upwhatever, that you try recopying the game files again, if you haven't already - it's entirely possible that this error is simply the result of a data corruption in your game files.

by SF/upwhatever, 10 years ago

Attachment: dw2-de.affected.md5.txt added

md5sum of my dw2 files

comment:3 by SF/upwhatever, 10 years ago

I installed the SVN build from http://www.scummvm.org/downloads/ in WindowsXP running in VirtualBox and re-copied all the files listed under http://wiki.scummvm.org/index.php/Datafiles#Discworld_2:_Missing_Presumed_....21.3F (except the english.* files are called german.*) from my CDs and imported my savegame.
=> same result.

Therefore this Problem is probably not related to linux. Either it's a bug which only affects the german version or my CDs might be somehow damaged. A friend of mine owns the german CD version too, so i'll try to borrow it and compare his files to mine...

attached: md5sum of my scummvm discworld2 folder.

comment:4 by SF/upwhatever, 10 years ago

Resolution: invalid
Status: newclosed

comment:5 by SF/upwhatever, 10 years ago

dreammaster was right, some of my data files were corrupt. I copied the files from my friend's CDs and the problem is gone.
Sorry for wasting your time.

Note: See TracTickets for help on using tickets.