Opened 10 years ago

Closed 10 years ago

#4366 closed defect (fixed)

LURE: NPC character got an excess number of pending actions

Reported by: SF/l3l3l5l Owned by: dreammaster
Priority: high Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

ScummVM version: ScummVM v0.13.1

Bug details: When entering bar with blood on walls or bar with fat bartender and browsing around for a while (max 5 minutes) - ScummVM throws in a console with the message: "ERROR: NPC character got an excessive number of pending actions". After which the progrm crashes. See screenshot: http://img189.imageshack.us/img189/8623/fullscreencapture613200.png

Language of game: English

Version of game: freeware (downloaded from scummvm.org)

Platform and Compiler: Vista Business 64 bit, ...

Ticket imported from: #2806012. Ticket imported from: bugs/4366.

Attachments (2)

lure.001 (24.8 KB ) - added by SF/l3l3l5l 10 years ago.
(supposedly) wait for 4 barman animations to see the program crash
lure.002 (27.5 KB ) - added by SF/l3l3l5l 10 years ago.
Date: 2009-06-14 06:34 promised attach

Download all attachments as: .zip

Change History (12)

comment:1 by SF/l3l3l5l, 10 years ago

ScummVM version: 0.14.0svn41485

Bug details: same bug appears in this version too when you just interfere with NPCs too much on (supposedly) any screen where you can meet NPCs. A crash occured when meeting a monk on screen with a sheep and a well.

comment:2 by dreammaster, 10 years ago

In order to properly investigate this problem, could you please attach some savegames to this bug report, preferably one from before entering the tavern, and one from after browsing around for several minutes (but before the crash occurs).

It would also be helpful to provide more exact instructions as what actions you did before the crash, since it may be a major factor in causing the bug.

by SF/l3l3l5l, 10 years ago

Attachment: lure.001 added

(supposedly) wait for 4 barman animations to see the program crash

comment:3 by SF/l3l3l5l, 10 years ago

I uploaded a save which reproduces the crash with 100% accuracy in my environment. To see the crash just wait for bartender to perform three animations. The program crashes on fourth.

ScummVM version: 0.14.0svn41485

comment:4 by SF/l3l3l5l, 10 years ago

The bug appeared a 100% reproducable when starting the game from scratch.

1) Launch scummvm 0.14.0svn41485
1.1) Press esc to skip intro
2) pull torch
3) wait for monster to come in
3) exit
4) close door with monster
5) lock door
6) go to right door
7) pick up knife
8) pick up bottle
9) go next door
10) use knife on leather straps
11) go back
12) look at barrel
13) use bottle on barrel tap
14) go to left door
15) give bottle to hanging man
16) ask ratpouch to push bricks and finish
17) go through hole (don't skip animation)
18) wait for ratpouch to appear and get off your way
19) navigate to blood stained bar street
20) preferably wait for old woman to come into the blood stained bar
21) enter bar
22) crash will occur really quick if you followed the instructions

I'll attach another save, which reproduces the bug after following above instructions.

P.S.: reminder - it's vista business 64, who knows if that's the case.

by SF/l3l3l5l, 10 years ago

Attachment: lure.002 added

Date: 2009-06-14 06:34 promised attach

comment:5 by sev-, 10 years ago

Summary: NPC character got an excessive number of pending actionsLURE: NPC character got an excess number of pending actions

comment:6 by sev-, 10 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:7 by sev-, 10 years ago

Priority: normalhigh

comment:8 by sev-, 10 years ago

Owner: set to dreammaster

comment:9 by dreammaster, 10 years ago

I've identified the problem.. an adjustment made to the Y position when a walking starts (y & 0xfff8) was placing the character (in this case Ratpouch) further into the exit area than he should ever be. Thus, when it added an extra action to have Ratpouch move to a random position in the current room (the idea being to give the blocking character time to move), it immediately detected it was still in the exit area, so started adding further 'set random dest' action entries until his schedule was full.

comment:10 by dreammaster, 10 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.