Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4311 closed defect (fixed)

KYRA1: Sound effect loops continuously (Mac CD)

Reported by: SF/nnooiissee Owned by: lordhoto
Priority: low Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 1

Description

After riding the branch down from the tree there is a ticking sound looping quickly. This persists onto other screens but a save and reload clears the sound.

Unsure whether this is SFX or Music.

Reproduction:

1. Start game The Legend of Kyrandia (CD/Macintosh/English) 2. Hit Esc and start a new game, or wait through the intro. 3. Attempt to exit treehouse to the south 4. Click or hit Esc repeatedly to speed up the conversation with the tree, or just wait it out. 5. Exit south 6. Exit tree to the south to ride the branch down

I can upload a save if needed.

Ticket imported from: #2772727. Ticket imported from: bugs/4311.

Change History (17)

comment:1 by lordhoto, 11 years ago

I can't reproduce this with my DOS/CD version. What audio driver did you select? MIDI? AdLib? Default?

Anyway I suspect this is a problem because of the current hack enabling DOS sounds in the Mac version, thus lowering priority.

comment:2 by lordhoto, 11 years ago

Owner: set to lordhoto
Priority: normallow

comment:3 by lordhoto, 11 years ago

Summary: Sound effect loops continuously (Mac CD)KYRA1: Sound effect loops continuously (Mac CD)

comment:4 by lordhoto, 11 years ago

Oh btw. you should be able to check whether it's sound effects or music by muting one via the Kyra in-game options menu.

comment:5 by SF/nnooiissee, 11 years ago

I was originally running with the audio driver of Default. Default, AdLib and mixed MIDI/AdLib trigger this bug while MIDI only (QuickTime) does not (but MIDI only is missing sound effects such as this one).

Tried changing volume controls. Unfortunately all (except for speech) sound is controlled by the Music volume setting. I am guessing this is a sound effect based on it not happening with MIDI only.

comment:6 by lordhoto, 11 years ago

You can mute the SFX via the Kyra in-game menu. Click on the blue jewel/button (in the DOS version it has written "Options" on it, but in my Kyra MAC floppy it doesn't, no idea how it behaves in your version) in the Kyra interface and a blue menu should open up.

I am still not able to reproduce this over here. Are you running a PPC Mac by chance (I remember you were an Mac user)? I could try that on my Mac some time and check whether it works fine here with my DOS version.

comment:7 by SF/nnooiissee, 11 years ago

Thanks for pointing that out. It's a sound effect.

Running an Intel Mac with 10.5.6 and this build: http://buildbot.scummvm.org/snapshots/trunk/os_x_intel-trunk-r39962.tar.bz2

100% reproducible for me. Could be a factor of either running on a Mac, of the Mac version, or both.

comment:8 by SF/nnooiissee, 11 years ago

Hearing same bug in http://buildbot.scummvm.org/snapshots/trunk/lenny-trunk-r39962.tar.bz2 with same data files so likely not related to the platform ScummVM is running on but instead to the data files.

Nothing is logged while the bug happens. Is there anything I can do to get more info on what is happening?

comment:9 by lordhoto, 11 years ago

You could provide the md5 sum for you 'ADL.PAK' file, maybe that one differs, but I doubt it.

No there's no way to get any additional logging.

comment:10 by SF/nnooiissee, 11 years ago

MD5 (SND.PAK) = 2e05c51a13870fa0bfdbaeb327df4752 MD5 (SONG.PAK) = 521f3975e2eb7d2eca3af666192c353b MD5 (ADL.PAK) = 947289d401b7b3496bb1cc79bcd2ad8d

Let me know if you would like a full list of md5s.

comment:11 by lordhoto, 11 years ago

The ADL.PAK file matches mine, the same goes for the other files too, but those are not related SND.PAK should contain PC Speaker sound data and SONG.PAK contains data for a specific in-game scene.

I guess it must be something different then, but I'm unsure what. I don't think I'll have any chance to debug this till I can get my hands on a Mac CD version. Could you supply md5sums for TRUNK.PAK and GEM.PAK?

Totally unrelated: Do you have any *.res files, btw.?

comment:12 by SF/nnooiissee, 11 years ago

MD5 (TRUNK.PAK) = 3ed222db55b44d303fd65929a5ce93fe MD5 (GEM.PAK) = e86db98c4e0d0179a0f24391b3234008

There is a RES folder on the disk containing four files: HQ_Music.res Halestorm.res LQ_Music.res Setup

LQ_Music.res contains SONG resources that effect the play back of midis. HQ_Music.res includes SONG resources, MIDI, snd sounds and INST resources that effect how each sound is used.

comment:13 by lordhoto, 11 years ago

Seems to be exactly the same datafiles as my DOS CD version. Really no idea why it loops all the time for you. I runned ScummVM via some memory checker (valgrind) and I didn't get any messages about possible corruptions, thus it *should* be fine.

Where was this other guy who claimed to have a Kyra 1 Mac CD version too (he supplied a patch which added md5sums for Mac CD), maybe we can contact him and check whether it happens for him too.

comment:14 by SF/nnooiissee, 11 years ago

From Staz (with permission). This apparently fixes some sound issues. I've been asked to try it and see if it fixes this, but I currently have no build environment.

Index: engines/kyra/sound.cpp

--- engines/kyra/sound.cpp (revision 40006) +++ engines/kyra/sound.cpp (working copy) @@ -239,7 +239,7 @@ // XXX //}

- if (_flags.platform == Common::kPlatformPC) { + if (_flags.platform == Common::kPlatformPC || _flags.platform == Common::kPlatformMacintosh) { assert(command*2+1 < _trackMapSize); if (_curMusicTheme != _trackMap[command*2]) { if (_trackMap[command*2] != -1 && _trackMap[command*2] != -2)

comment:15 by lordhoto, 11 years ago

I committed that one, but it should only affect music not sfx, so I doubt it'll fix this issue.

comment:16 by lordhoto, 11 years ago

Ok just tried out faking my DOS version as Macintosh version and yeah after that fix it was gone. Now I guess it was that previously it didn't load the correct sound file, thus the sfx played was bugged. Ok closing this one as fixed then.

comment:17 by lordhoto, 11 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.