Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4300 closed defect (wontfix)

IHNM: Game freezes when playing as Benny

Reported by: SF/junker90287 Owned by: bluegr
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: I Have No Mouth

Description

The game always locks up when trying to go to sleep using Benny for the last time. The screen changes to the outdoor picture of the caves, darkens slightly and then freezes.

The music continues and pressing Z still pauses and unpauses the game but nothing else happens and the disk menu icon is absent.

I'm using the latest subversion of ScummVM (0.14.0svn39897), playing the English DOS version of IHNM, on Windows XP Professional SP3.

Ticket imported from: #2745521. Ticket imported from: bugs/4300.

Attachments (1)

ihnm.s00 (20.6 KB ) - added by SF/junker90287 12 years ago.
IHNM save game file

Download all attachments as: .zip

Change History (15)

comment:1 by SF/junker90287, 12 years ago

Summary: Game freezes when playing as BennyIHNM:Game freezes when playing as Benny

comment:2 by SF/junker90287, 12 years ago

Summary: IHNM:Game freezes when playing as BennyIHNM: Game freezes when playing as Benny

comment:3 by eriktorbjorn, 12 years ago

I played through the Benny chapter without encountering any major problems. Only several small glitches, but I think at least some of them were in the original game as well. But as far as I know, there are several optional parts so I may not have reproduced your case properly. Perhaps you have a savegame shortly before the problem that you could attach to the bug report?

(I probably won't have a clue how to fix it, even with a savegame, but others might.)

comment:4 by SF/junker90287, 12 years ago

Really? Kept freezing for me... Have you tried playing his chapter after you've finished Gorrister's and Ellen's first? At least that's how I've done it.

I actually tried attaching a savegame to this report, but I kept getting an error saying the file's size was too large. Should I try putting it on some random uploading site and put the link in a comment, or is that sort of thing frowned upon around here?

comment:5 by SF/junker90287, 12 years ago

Never mind, managed to upload the file. I think...

comment:6 by eriktorbjorn, 12 years ago

No, I haven't tried playing that chapter after the others. At least not recently. That file seems much too small to be a savegame. It's only 15 bytes, once you unpack it. Anyway, isn't SCREAM.SAV something you get when you play it with the original interpreter, e.g. in DOSBox?

comment:7 by SF/junker90287, 12 years ago

That's the file I got when I saved the game using ScummVM. I never tried playing IHNM on DOSBox, so I wouldn't know.

Though I'm starting to think that maybe the freeze glitch might have something to do with the fact that I was still using the 0.13.0 stable version of ScummVM when I made that save. I think I might have ended doing certain things out of sequence, or have Benny sleep one too many times when normally it shouldn't be possible to do so. I'll go try Benny's chapter again from scratch with the 0.14.0 version and see how that goes.

comment:8 by eriktorbjorn, 12 years ago

Strange, I'm pretty sure ScummVM never creates SCREAM.SAV, and it's not created when I install the game from my CD. It is created when I run the game in DOSBox, though.

comment:9 by SF/junker90287, 12 years ago

I managed to find the right file. I'll update the attachment right away.

by SF/junker90287, 12 years ago

Attachment: ihnm.s00 added

IHNM save game file

comment:10 by eriktorbjorn, 12 years ago

I can reproduce the problem with that savegame. (I have no idea why it happens, though.)

comment:11 by SF/junker90287, 12 years ago

I assume I did something out of sequence and the game wasn't able to cope with it. Though when I tried it again starting from the beginning of the chapter using the 0.14.0 subversion from the start, I was able to finish the chapter with only minor glitches just like you said. I guess the glitch could possibly only be reproduced with the 0.13.0 stable version.

comment:12 by bluegr, 12 years ago

This savegame is interesting. It's corrupted, and it makes it impossible to comtinue, as a game script variable seems to have been corrupted somehow. The game scripts are trying to make Benny say "BUG!!! What day is it?" before the nightfall scene finishes, but since the actor is hidden during the nightfall scene, and since the game is actually waiting for the actor to speak at this point, we got a deadlock. This seems to be a game script bug, and we can do nothing about it :( You need to play this part again, like you did.

As you said yourself, something was done out sequence, or was unexpected, and the game scripts couldn't handle it...

Closing as "won't fix"

comment:13 by bluegr, 12 years ago

Owner: set to bluegr
Resolution: wontfix
Status: newclosed

comment:14 by bluegr, 12 years ago

In the latest unstable version, I've added a new console command, "wake_up_threads", which can be used to bypass this, but the game will probably freeze later on anyway

Note: See TracTickets for help on using tickets.