Opened 18 years ago

Closed 17 years ago

Last modified 9 months ago

#43 closed defect (worksforme)

DOTT:Crash at the talk with T. Jefferson

Reported by: SF/grumbel Owned by: SF/strigeus
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

When Hoggie does it first talk with Thomas Jefferson
scummvm crashes. I am using the german CD version of
Day of the Tentacle and the crash happens at the end of
the sentance "Ich bin, selbstverstaendlich
Thomas Jefferson beruehmter Gelehrter Musiker,
Reiter...". It is reproducable and does only happen at
the first talk with Jefferson, it does not crash at
later talks with Thomas Jefferson or any other persons.
It was the only crash of scummvm that I found in the
whole game.

Here is a backtrace:

0x0806052e in MixerChannel::mix (this=0x808e9c0,
data=0x8094fea, len=7) at sound.cpp:437
437
*data++ += (*s<<6);
(gdb) where
#0 0x0806052e in MixerChannel::mix (this=0x808e9c0,
data=0x8094fea, len=7) at sound.cpp:437
#1 0x0806060b in Scumm::mixWaves (this=0x808b0c0,
sounds=0x8094e90, len=2048) at sound.cpp:462
#2 0x08064362 in fill_sound (userdata=0x807b220,
stream=0x8094e90
"????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????"...,

len=4096) at sdl.cpp:483
#3 0x4003b319 in SDL_RunAudio () from
/usr/lib/libSDL-1.2.so.0
#4 0x40070a67 in SDL_RunThread () from
/usr/lib/libSDL-1.2.so.0
#5 0x40070c5e in SDL_KillThread () from
/usr/lib/libSDL-1.2.so.0
#6 0x4009aeca in pthread_start_thread () from
/lib/libpthread.so.0
#7 0x4009af11 in pthread_start_thread_event () from
/lib/libpthread.so.0

Ticket imported from: #487257. Ticket imported from: bugs/43.

Change History (9)

comment:1 Changed 18 years ago by SF/strigeus

Owner: set to SF/strigeus

comment:2 Changed 17 years ago by SF/ender

Really old bug - Can't replicate it with current CVS.

comment:3 Changed 17 years ago by SF/ender

Resolution: worksforme
Status: newclosed

comment:4 Changed 17 years ago by SF/grumbel

I can still reproduce this with the current scummvm CVS. It
might be special problem with the german CD version of DOTT
(the one from the "LucasArts Zehn Adventures" pack, not the
original CD release). I'll attach some md5sum's of the DOTT
files, just in case that this might be a problem with the
DOTT copy and not with scummvm:

def7539c724d71f6029a32a3e43ef38c adlib.ims
a5184bd4d8e00580fc8d71b147f88e52 dott.bat
d5ba6e4eb6fd21740b2d2e46b8f04225 dotticon.ico
50b1cbc88f7509fc3054909ea7b36b13 gmidi.ims
8ea07a3e13af00f0a6e594820df1a9af monster.sou
2e55df1844c022e3e70ca9c8138cf86b null.ims
75ee0168eda894babef861bdefef875b roland.ims
6e959d65358eedf9b68b81e304b97fa4 tentacle.000
0913cd05019c6821c672f1d84a8fc36d tentacle.001
ad3bb485e0a74e0e5117ea6e16eae765 tentacle.exe
877daf58b962992729426c6e9b1222c3 tentacle.pif

comment:5 Changed 17 years ago by SF/grumbel

Status: closednew

comment:6 Changed 17 years ago by SF/ender

Status: newclosed

comment:7 Changed 17 years ago by SF/ender

I'm closing this again because other German players can't
reproduce it... sorry Grumble

comment:8 Changed 17 years ago by SF/mkarcher

I can reproduce the bug with exactly the same version as
mentioned ("Zehn Adventures"). The problem is fixed by my
patch with id 550951.

comment:9 Changed 9 months ago by digitall

Component: Engine: SCUMM
Game: Day of the Tentacle
Note: See TracTickets for help on using tickets.