Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#4160 closed defect (fixed)

SWORD1: palette glitches during scene changes in endgame

Reported by: wjp Owned by: wjp
Priority: low Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

In the final scene where the Grand Master restores the broken sword, camera viewpoint changes are accompanied by a brief flash or wrong colours, seemingly a palette change occurring just too early or late.

It may also have happened earlier, but in this scene it was very noticable. Savegame just before the scene attached. Just walk to the rear of the screen.

This is with Gentoo on amd64, English talkie BS1, DXA video, scummvm 0.13 branch from 2009-02-13.

Ticket imported from: #2599963. Ticket imported from: bugs/4160.

Attachments (2)

sword1.027 (1.0 KB ) - added by wjp 12 years ago.
savegame
bs1-palette.diff (1.8 KB ) - added by eriktorbjorn 12 years ago.
Patch against current SVN

Download all attachments as: .zip

Change History (6)

by wjp, 12 years ago

Attachment: sword1.027 added

savegame

comment:1 by wjp, 12 years ago

Priority: normallow

by eriktorbjorn, 12 years ago

Attachment: bs1-palette.diff added

Patch against current SVN

comment:2 by eriktorbjorn, 12 years ago

I think the problem is that this is one of the few (perhaps the only) places where the palette is changed immediately, rather than faded. In this particular case, it's probably better to do the palette change in updateScreen() rather than newScreen(). I'm attaching a patch to show what I mean, but there may be some simpler way of doing it. (There's some duplication of code.) File Added: bs1-palette.diff

comment:3 by wjp, 11 years ago

Committed an adapted patch. It works in all the scene changes I tested, but probably needs more testing.

comment:4 by wjp, 11 years ago

Owner: set to wjp
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.