Opened 12 years ago

Closed 12 years ago

#4159 closed defect (fixed)

SWORD1: inventory visible in death scene in Syria

Reported by: wjp Owned by: wjp
Priority: low Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

In Syria, on Bull's Head, after distracting Kahn with the palm buzzer, move the cursor to the inventory area at the top of the screen. If you wait a couple of seconds, Kahn will recover and shoot you. In the next shot, you'll see yourself lying dead, with the inventory bar in roughly inverted colours at the top of the screen. See the attached screenshot and savegame.

The savegame is made directly after using the palm buzzer.

This is with Gentoo on amd64, English talkie BS1, DXA video, scummvm 0.13 branch from 2009-02-13.

Ticket imported from: #2599573. Ticket imported from: bugs/4159.

Attachments (2)

sword1.016 (940 bytes ) - added by wjp 12 years ago.
savegame
death_inventory_glitch.png (145.2 KB ) - added by wjp 12 years ago.
screenshot

Download all attachments as: .zip

Change History (6)

by wjp, 12 years ago

Attachment: sword1.016 added

savegame

by wjp, 12 years ago

Attachment: death_inventory_glitch.png added

screenshot

comment:1 by eriktorbjorn, 12 years ago

Probably a regression from earlier versions. We use the lockScreen() / unlockScreen() API now, which forces the entire screen to be redrawn each frame of the DXA movie.

Maybe add _system->clearScreen() to MoviePlayer::play(). The call to _screen->clearScreen() could, theoretically, still be needed, since that clears the engine's own screen buffer, while the one in _system clears the backend's screen buffer.

comment:2 by lordhoto, 12 years ago

Or we just use OSystem::clearScreen in Screen::clearScreen. As wjp pointed out in IRC Screen::clearScreen is only used by MoviePlayer::play, thus I guess it should be safe to do so.

comment:3 by wjp, 12 years ago

Owner: set to wjp
Resolution: fixed
Status: newclosed

comment:4 by wjp, 12 years ago

I tested and committed LordHoto's suggestion to trunk and the 0.13 branch.

Note: See TracTickets for help on using tickets.