Opened 17 years ago

Closed 17 years ago

Last modified 13 years ago

#413 closed defect (fixed)

SIMON2: doesn\'t run (opcode problem?)

Reported by: SF/lethalwp Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 2

Description

when started with scummvm -eseq simon2dos
i have:

Debugmode (level 9) on
Detected game 'Simon the Sorcerer 2 for Dos', version
99.99.99
WARNING: No path was provided. Assuming the data files
are in the current directory!
right opcode table
right opcode table
<snip>
right opcode table
right opcode table
Error: Unable to locate opcode table. Perhaps you are
using the wrong game target?!

i have tried in upper & lower case file names

Ticket imported from: #595815. Ticket imported from: bugs/413.

Change History (16)

comment:1 by fingolfin, 17 years ago

Summary: simon2dos doesn't run (opcode problem?)SIMON2: doesn't run (opcode problem?)

comment:2 by fingolfin, 17 years ago

What version of ScummVM do you use? And on what
OS? You should always include this information in bug
reports (for any project where you report bugs, BTW).

comment:3 by SF/lethalwp, 17 years ago

using linux, latest cvs release

Do you need some files so you can check them?

comment:4 by SF/ender, 17 years ago

Owner: set to SF/ender

comment:5 by SF/ender, 17 years ago

Have you actually tried 'simon2win' by any chance?

This error means it couldn't locate the opcode table (wow :) in that game.
So either your using the wrong 'target' - eg, simon2dos vs simon2win - or
you have a modified version of the game.

As we here at ScummVM do not support piracy, if it's the second problem,
then we can only help if you are willing and able to send us an original copy
of the game in question.

Please let me know if Simon2Win works. If not, I'll have to close this bug
report, as there's nothing else we can do.

comment:6 by SF/lethalwp, 17 years ago

tried both 2dos and 2win
but this should actually be a dos version

comment:7 by fingolfin, 17 years ago

What is the status of this item?

comment:8 by SF/lethalwp, 17 years ago

the simon2 version i have here still produces the same error
and won't run

No solution yet

comment:9 by fingolfin, 17 years ago

We are unable to reproduce this with our data files. Thus we can't fix
this. I recommend closing this as "Works for me"

comment:10 by Kirben, 17 years ago

Owner: changed from SF/ender to Kirben

comment:11 by Kirben, 17 years ago

This problem should now be fixed, try latest scummvm cvs.

comment:12 by Kirben, 17 years ago

Resolution: fixed
Status: newclosed

comment:13 by Kirben, 17 years ago

Component: Engine: AGOS
Game: Simon the Sorcerer 1
Owner: Kirben removed
Status: closednew

comment:14 by Kirben, 17 years ago

Component: Engine: AGOS
Game: Simon the Sorcerer 2
Owner: set to Kirben
Status: newclosed

comment:15 by fingolfin, 14 years ago

Component: Engine: AGOSEngine: AGI
Game: Simon the Sorcerer 2AGI Fanmade

comment:16 by Kirben, 13 years ago

Component: Engine: AGIEngine: AGOS
Game: AGI FanmadeSimon the Sorcerer 2
Summary: SIMON2: doesn't run (opcode problem?)SIMON2: doesn\'t run (opcode problem?)
Note: See TracTickets for help on using tickets.