Opened 17 years ago

Closed 17 years ago

Last modified 13 years ago

#412 closed defect (fixed)

SIMON: fails to initialise midi

Reported by: SF/lethalwp Owned by: fingolfin
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

problem is the following:
the game begins (showing weird, some ppl reported it in
the forum)
Detected game 'Simon the Sorcerer 1 for DOS', version
99.99.99
WARNING: No path was provided. Assuming the data files
are in the current directory!
WARNING: readSfxFile: Cannot load sfx file SFXXXX01!
WARNING: readSfxFile: Cannot load sfx file SFXXXX05!
WARNING: Set video mode internal: 0, 16202!
WARNING: Set video mode internal: 0, 16201!
WARNING: Set video mode internal: 0, 16200!

then asks for the codes, but it allways asks the same
things:
pentagon? page 17, feather page 6, skull page 22

i passed it once pressing West; South; W-S, and was
amazed to see the introduction

after closing it and re-run, the code asked were still
the same, but replying the same didn't work?

so i suppose the code is random, but there's a problem
at asking the correct one

Ticket imported from: #595813. Ticket imported from: bugs/412.

Change History (15)

comment:1 by SF/lethalwp, 17 years ago

Summary: simon1dos: can't pass the codessimon1dos: fails to initialise midi

comment:2 by SF/lethalwp, 17 years ago

Hmm after digging a bit more, the problem doesn't come of
the codes, i didn't remembered i had a cracked copy ;) So
the codes were always true.

I retried with the normal version, there i can see if i pass
the codes or not, and if i fail, the msg is: " Error: Exit
interpreter opcode!"

The problems comes of the midi initialisation that fails
most of the time
( -eseq && -ealsa )
What i don't get is that i've heard the music once

error showing is:
Error: MidiPlayer::initializer, got Streaming not available!

Digging more to get more infos

comment:3 by fingolfin, 17 years ago

Summary: simon1dos: fails to initialise midiSIMON: fails to initialise midi

comment:4 by fingolfin, 17 years ago

What version of ScummVM do you use? And on what
OS? You should always include this information in bug
reports (for any project where you report bugs, BTW).

comment:5 by SF/lethalwp, 17 years ago

i use linux kernel 2.4, with latest cvs of scummvm

i've foudn that the sound is working when no -e option is passed
but it gives a lot of "MIDI sub-command 0xB0 (Control
Change) case 79 not handled in MIDIEMU driver.
MIDI sub-command 0xB0 (Control Change) case 79 not handled
in MIDIEMU driver.
" errors, and the sound is "nerves-working", but it works

if passed to a midi sequencer with -eseq or -ealsa, then it
fails to initialise

maybe this is just a 'missing feature'?

comment:6 by Kirben, 17 years ago

The midi music in Simon 1/2 (simon1win/simon2win targets)
fails to play under Windows too.

comment:7 by Kirben, 17 years ago

The problem of no midi play on win32 was caused by change
at http://cvs.sourceforge.net/cgi-
bin/viewcvs.cgi/scummvm/scummvm-
old/simon/simon.cpp.diff?r1=1.31&r2=1.32
That added -1 is last line of changes seems to be only midi
related change, if I remove the -1 from current cvs verison midi
works in simon1win again but simon2win crashes.on startup.

comment:8 by fingolfin, 17 years ago

I checked in a change following Kirben's findings - it does the -1 one
only for Simon2, not for Simon1. Can somebody check if that helps any
(i.e. do all versions now work correctly, or not)?

comment:9 by Kirben, 17 years ago

Yes, the midi in simon1win works again in Windows :)
That added -1 isn't actually required for midi play back in
simon1win or simon2win targets.
The cause of the simon2win crash I mentioned earlier is
caused by the change at http://cvs.sourceforge.net/cgi-
bin/viewcvs.cgi/scummvm/scummvm/simon/simon.cpp.diff?
r1=1.6&r2=1.7 that changes in the last section I expect.

comment:10 by fingolfin, 17 years ago

I just fixed Simon2win MIDI, too (at least here). Feel free to reopen if it
still fails for you now.

comment:11 by fingolfin, 17 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:12 by Kirben, 17 years ago

Component: Engine: AGOS
Game: Simon the Sorcerer 1
Owner: fingolfin removed
Status: closednew

comment:13 by Kirben, 17 years ago

Component: Engine: AGOS
Game: Simon the Sorcerer 1
Owner: set to fingolfin
Status: newclosed

comment:14 by fingolfin, 14 years ago

Component: Engine: AGOSEngine: AGI
Game: Simon the Sorcerer 1Space Quest 1

comment:15 by Kirben, 13 years ago

Component: Engine: AGIEngine: AGOS
Game: Space Quest 1Simon the Sorcerer 1
Note: See TracTickets for help on using tickets.