Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4105 closed defect (fixed)

DW: music won't play

Reported by: SF/meddlingmonk Owned by: wjp
Priority: normal Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld

Description

Self-built binaries on two machines: a PPC Mac and a PC running Fedora 10. All latest dev tools available are on both machines. On both computers Discworld music will not play, neither the original MIDI nor the enhanced-music ogg files. Voice and SFX work. Music plays with Discworld II (and all other games I have in ScummVM). No errors are output on either machine. Haven't noticed any compile errors.

Ticket imported from: #2531282. Ticket imported from: bugs/4105.

Change History (6)

comment:1 by fingolfin, 12 years ago

Summary: Discworld music won't playDW: music won't play

comment:2 by wjp, 12 years ago

The enhanced-music ogg files need to be named track01.ogg, track02.ogg, etc... I believe the currently downloadable tracks are named 01.ogg, 02.ogg, etc...

As for the MIDI not working: after it fails to find the .ogg tracks, it tries to fall back to trying to play a real audio CD. This is made to look successful whether or not it actually could play a CD track. (Maybe because of timing issues in other games? Unsure.)

comment:3 by SF/meddlingmonk, 12 years ago

Prepending 'track' to all the ogg files fixes that problem. I jumped on the ogg files because MIDI music wasn't playing (more exactly, after MIDI stopped playing...it once did several builds ago), and I've confirmed that the MIDI music still won't play by removing the renamed ogg files from my discworld folder. So what's happening? Is it looking for oggs first, audio CD second and assuming it's playing no matter what and giving MIDI a miss altogether?

comment:4 by wjp, 12 years ago

Yes, that's what's currently happening. I'm glad the 'track' fixed the enhanced audio. We'll have to fix the remaining MIDI problem.

Thanks for reporting this.

comment:5 by wjp, 12 years ago

This should now be fixed.

comment:6 by wjp, 12 years ago

Owner: set to wjp
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.