Opened 12 years ago

Closed 12 years ago

#3993 closed defect (fixed)

BS1: Can't overwrite savegame

Reported by: SF/simsaw Owned by: eriktorbjorn
Priority: normal Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

When trying to overwrite an existing game, it just doesn't save the current savegame and even no error message is displayed. For every new savegame the user must currently save a new save game and delete files manually so that he won't have to scroll down a too long list, which is rather uncomfortable.

Ticket imported from: #2162345. Ticket imported from: bugs/3993.

Change History (4)

comment:1 by eriktorbjorn, 12 years ago

The problem seems to be that Broken Sword 1 assumes that you always want to save to the next available save slot.

Part of this can probably be fixed by changing Control::saveToFile() so that it calls saveGameToFile(_selectedSavegame) instead of saveGameToFile(_numSaves), but that still doesn't seem to allow any "gaps" in the list of files. For instance, if you have savegames in all slots up to and including 25, and try to save to slot 30, that doesn't work as expected. It's too late at night to figure out why right now.

comment:2 by eriktorbjorn, 12 years ago

The other part of the problem seems to be that it removes any "gap" in the list of savegames when filling the save/load dialog. I believe I have fixed this in the current development version of ScummVM, but I'd appreciate it if someone could test it further before I close this. (And probably apply it to the 0.12 branch as well.)

comment:3 by eriktorbjorn, 12 years ago

It looks like the first part of the bug was a recent regression in the trunk. Since I haven't heard any further comments, I'm going to assume that this is fixed now. I've backported the second part of the fix (allowing gaps in the savegame list) to 0.12.

comment:4 by eriktorbjorn, 12 years ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.