Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3876 closed defect (fixed)

FW: Spaceship glitches in demo (regression)

Reported by: Kirben Owned by: SF/buddha_
Priority: normal Component: Engine: Cine
Keywords: Cc:
Game: Future Wars

Description

ScummVM 0.13.0svn (Aug 18 2008 10:20:36) Compiled under mingw with GCC 4.2.1-dw2 Running on Windows XP Media Center 2005 Edition Amiga demo of Future Wars

The image of the top part of the spaceship isn't displayed correctly in the Amiga demo of Future Wars.

I expect this problem is due to a decode failure, since the following warnings are reported: WARNING: Error unpacking 'L004.ANI' from bundle file 'DEMO'! WARNING: _activeLowPal is invalid!

This problem is specific to ScummVM 0.13.0svn, and doesn't occur in the ScummVM 0.12.0pre branch.

Ticket imported from: #2057637. Ticket imported from: bugs/3876.

Attachments (2)

scummvm0.13.0.png (24.2 KB ) - added by Kirben 11 years ago.
scummvm0.12.0.png (23.6 KB ) - added by Kirben 11 years ago.

Download all attachments as: .zip

Change History (6)

by Kirben, 11 years ago

Attachment: scummvm0.13.0.png added

by Kirben, 11 years ago

Attachment: scummvm0.12.0.png added

comment:1 by Kirben, 11 years ago

File Added: scummvm0.12.0.png

comment:2 by SF/buddha_, 11 years ago

Resolution: fixed
Status: newclosed

comment:3 by SF/buddha_, 11 years ago

I changed unpacking not to unpack data in-place and the glitch vanished so this seems to be caused by revision 33781 where I changed readBundleFile to unpack data in-place (As that's what the original also does AFAIK, but it would seem that I am wrong on this).

Fixed in trunk in revision 34034: http://scummvm.svn.sourceforge.net/scummvm/?rev=34034&view=rev

Fixed in branch-0-12-0 in revision 34035: http://scummvm.svn.sourceforge.net/scummvm/?rev=34035&view=rev

SVN log message for the bugfix:

Fix for bug #2057637: FW: Spaceship glitches in demo (regression). This was caused by assuming in-place decompression is ok, it wasn't, although AFAIK the original did decompression in-place too. Changed unpacking to be done not in-place and the glitch vanished. Also changed the unpacker to also handle uncompressed input data.

comment:4 by SF/buddha_, 11 years ago

:D It *doesn't* occur on the 0.12.0pre branch, ooookay. Well, the fix the I backported to the 0.12.0 branch makes all unpacking to be done not in-place so it's a good precaution anyway, shouldn't be any harm done (Knocks wood, knocks head).

Note: See TracTickets for help on using tickets.