Opened 12 years ago

Closed 12 years ago

#3875 closed defect (fixed)

FW: Glitches in title display of demo (regression)

Reported by: Kirben Owned by: SF/buddha_
Priority: normal Component: Engine: Cine
Keywords: Cc:
Game: Future Wars

Description

ScummVM 0.12.0pre (Aug 18 2008 10:08:07) ScummVM 0.13.0svn (Aug 18 2008 10:20:36) Compiled under mingw with GCC 4.2.1-dw2 Running on Windows XP Media Center 2005 Edition Amiga demo of Future Wars

The background behind the title name, is no longer displayed correctly in the Amiga demo of Future Wars. The background behind the title name is blanked out, instead of been displayed over the current background image.

Compare the screenshots from ScummVM 0.11.1 and ScummVM 0.12.0pre.

Ticket imported from: #2057619. Ticket imported from: bugs/3875.

Attachments (2)

scummvm0.11.1.png (21.3 KB ) - added by Kirben 12 years ago.
scummvm0.12.0.png (15.9 KB ) - added by Kirben 12 years ago.

Download all attachments as: .zip

Change History (13)

by Kirben, 12 years ago

Attachment: scummvm0.11.1.png added

by Kirben, 12 years ago

Attachment: scummvm0.12.0.png added

comment:1 by Kirben, 12 years ago

File Added: scummvm0.12.0.png

comment:2 by Kirben, 12 years ago

Summary: FW: Glitches in title display (regression)FW: Glitches in title display (regression) of demo

comment:3 by Kirben, 12 years ago

Summary: FW: Glitches in title display (regression) of demoFW: Glitches in title display of demo (regression)

comment:4 by SF/buddha_, 12 years ago

According to my tests this regression was introduced in revision 32257 (Patch #1969189: "CinE renderer rewrite"): http://scummvm.svn.sourceforge.net/viewvc/scummvm?view=rev&revision=32257

comment:5 by SF/buddha_, 12 years ago

The logo seems to have to do with these entries:

animDataTable[89]: Size = 176 x 11, _bpp = 4 animDataTable[90]: Size = 176 x 11, _bpp = 4 animDataTable[91]: Size = 176 x 11, _bpp = 4 animDataTable[92]: Size = 176 x 57, _bpp = 4

"TITRE.ANI" is loaded to animDataTable entry 92 and "NOMS.ANM" is loaded to animDataTable entries 89-91.

TITRE.ANI's size is just the size of the black box behind the title name.

comment:6 by SF/buddha_, 12 years ago

Resolution: fixed
Status: newclosed

comment:7 by SF/buddha_, 12 years ago

Fixed in the trunk in revision 34039: http://scummvm.svn.sourceforge.net/scummvm/?rev=34039&view=rev

Fixed in the branch-0-12-0 in revision 34040: http://scummvm.svn.sourceforge.net/scummvm/?rev=34040&view=rev

It seems the problem was caused by using an incorrect transparency color for "TITRE.ANI". In revision 32257 an entry {"TITRE", 0xF} was added to transparencyData array in engines/cine/anim.cpp: http://scummvm.svn.sourceforge.net/viewvc/scummvm/scummvm/trunk/engines/cine/anim.cpp?view=diff&r1=32256&r2=32257

I removed that entry (I looked at Future Wars's PC version's disassembly and couldn't find an entry for TITRE although I did find lots of other entries so I think it's ok) and now it works.

comment:8 by SF/buddha_, 12 years ago

Resolution: fixed
Status: closednew

comment:9 by SF/buddha_, 12 years ago

It seems my previous fix to this bug broke some other versions of Future Wars so I'm opening this bug up again. I'm going to look into fixing this a bit better.

comment:10 by SF/buddha_, 12 years ago

Resolution: fixed
Status: newclosed

comment:11 by SF/buddha_, 12 years ago

Versions of TITRE.ANI with height 37 use color 0xF for transparency. Versions of TITRE.ANI with height 57 use color 0x0 for transparency. Now both versions are supported correctly.

I've seen three different versions of TITRE.ANI in Future Wars:

1) Filesize = 5038 Height = 57 Md5sum = e0b29471d74b3046406f69ffc7aaaca8 Versions = All French versions (Amiga, Atari ST, PC)

2) Filesize = 5038 Height = 57 Md5sum = 3def893ee236e2d2d46b791d4c75badc Versions = All non-French Amiga versions, English Atari ST version

3) Filesize = 3278 Height = 37 Md5sum = af3b1d18fabddd377e77c86e8d041a54 Versions = Spanish, German, English PC versions

Fixed in the trunk in revision 34081: http://scummvm.svn.sourceforge.net/scummvm/?rev=34081&view=rev

Fixed in branch-0-12-0 in revision 34082: http://scummvm.svn.sourceforge.net/scummvm/?rev=34082&view=rev

Note: See TracTickets for help on using tickets.