Opened 11 years ago

Closed 10 years ago

#3861 closed defect

SWORD1: Glitching after unplugging floor machine

Reported by: SF/labbott Owned by: hkzlab
Priority: normal Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

This is the point in the game where George is in the Hospital with the janitor. Best described in series of steps:

1) Unplug the floor machine
2) Game appears to progress correctly, janitor says "Take that you stupid thing" kicks floor machine
3) The image of both the floor machine and janitor disappear completely at the point where the janitor is supposed to walk over and plug the machine back in
4) George follows and walks to the correct spot. (His behavior is always normal)
5) The image of the janitor reappears when the janitor gets to the right side of the middle barrier. (i.e. where he would have reappeared after walking back from behind the barrier) The floor machine is still not present at this point.
6) The floor machine and janitor go back to normal (sweeping the floor etc.) but I can't click on anything. The cursor is not present anywhere and I can't activate inventory or menu screen to save.

-During this entire time, from steps 1 to 6, I can't activate the cursor to click on anything (i.e. solve the puzzle) or try and save state.
-I had previously unplugged the machine and had it work successfully (i.e. not glitch and I could keep playing) at least once before.

English Talkie Version of the Broken Sword 1
Gentoo Linux on x86_64, scummvm version from portage

labbott@godot ~/scumm $ scummvm --version
Using configuration file: /home/labbott/.scummvmrc
ScummVM 0.11.1 (Jul 31 2008 22:13:04)
Features compiled in: Vorbis MP3 ALSA zLib MPEG2

I don't have the ability to take screenshots at the moment, but I can set it up if needed

Ticket imported from: #2052323. Ticket imported from: bugs/3861.

Attachments (1)

SAVEGAME.014 (826 bytes ) - added by SF/labbott 11 years ago.
savegame from Broken Sword 1. George is in the Hospital with the janitor. Unplug the floor machine to see bug.

Download all attachments as: .zip

Change History (11)

by SF/labbott, 11 years ago

Attachment: SAVEGAME.014 added

savegame from Broken Sword 1. George is in the Hospital with the janitor. Unplug the floor machine to see bug.

comment:1 by fingolfin, 11 years ago

Owner: set to joostp

comment:2 by fingolfin, 11 years ago

Joost, any idea on this one?

comment:3 by fingolfin, 11 years ago

Owner: changed from joostp to lavosspawn

comment:4 by fingolfin, 11 years ago

Err, sorry, I meant Robert, not joost :)

comment:5 by sev-, 10 years ago

Owner: changed from lavosspawn to hkzlab

comment:6 by hkzlab, 10 years ago

Hi,
while i was able to reproduce the bug with your specific savegame, the game worked flawlessly with my savegames made with a newer version of ScummVM. I've tested English PC, Italian PC and English PSX versions, and all worked fine.

Can you retest the bug with current ScummVM version and with a fresh game?
Also, to trigger the bug, did you enter/exit the room multiple times or did other specific actions beside those in the original report?

comment:7 by hkzlab, 10 years ago

Status: newpending

comment:8 by hkzlab, 10 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:9 by SF/sf-robot, 10 years ago

Status: pendingclosed

comment:10 by SF/sf-robot, 10 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

Note: See TracTickets for help on using tickets.