Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3817 closed defect (fixed)

WOODRUFF: Wrong placement of Sprites after loading a game

Reported by: raziel- Owned by: DrMcCoy
Priority: blocker Component: Engine: Gob
Keywords: script Cc:
Game: Woodruff

Description

ScummVM 0.12.0svn (Jul 17 2008 15:30:31)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

The Sprites (in my examples it's the "Sad Bozook" and
the woman's poster) are placed in the top left corner
instead being placed on their respective positions on
screen after loading a saved game.

The hotspots for their sprites are still in the right
position though. One can move the cursor over the
misplaced sprite and gets nothing displayed, but
moving it over the correct position (where they used to
be) the text is being diaplyed and interaction is
possible.

I know of the incompatible save games, but maybe
someone from the team has my version aswell to test
and debug (I am also offering my version on CD for
debugging for the time it will take to the team - Let
me know)

The Bizarre Adventures of Woodruff and the Schnibble (DOS/English (GB))

AmigaOS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #2021204. Ticket imported from: bugs/3817.

Attachments (4)

woodruff-gb.s00 (8.6 KB ) - added by raziel- 11 years ago.
Sad Bozook save
GOB_Woodruff_Wrong_Sprite_Placement_1.png (64.5 KB ) - added by raziel- 11 years ago.
Sad Bozook misplaced
woodruff-gb.s01 (6.4 KB ) - added by raziel- 11 years ago.
Poster save
GOB_Woodruff_Wrong_Sprite_Placement_2.png (123.9 KB ) - added by raziel- 11 years ago.
Poster misplaced

Download all attachments as: .zip

Change History (13)

by raziel-, 11 years ago

Attachment: woodruff-gb.s00 added

Sad Bozook save

by raziel-, 11 years ago

Sad Bozook misplaced

comment:1 by raziel-, 11 years ago

File Added: GOB_Woodruff_Wrong_Sprite_Placement_1.png

by raziel-, 11 years ago

Attachment: woodruff-gb.s01 added

Poster save

comment:2 by raziel-, 11 years ago

File Added: woodruff-gb.s01

by raziel-, 11 years ago

Poster misplaced

comment:3 by raziel-, 11 years ago

File Added: GOB_Woodruff_Wrong_Sprite_Placement_2.png

comment:4 by DrMcCoy, 11 years ago

Just old saves, or new saves as well?

Because I did fix a mistake that might have rendered saves made between revisions 32352 (2008-05-28 - the fix that made Woodruff playable on big endian systems in the first place) and 33014 (2008-07-12) in several cases invalid...
(To be precise, I forgot that the engine maps some pointers onto addresses within the variables array in several places)

Sorry for the inconvenience.

comment:5 by DrMcCoy, 11 years ago

Owner: set to DrMcCoy
Priority: normalblocker

comment:6 by sev-, 11 years ago

Raising priority. This is a release-critical bug.

comment:7 by raziel-, 11 years ago

Can be closed.

I was using an old save without cross checking with a newer
one. Works flawless.

Sorry for the trouble :-/

comment:8 by DrMcCoy, 11 years ago

There was another fix yesterday, revisions 33222/33223 (trunk/0.12.0-branch). Saves for LE games on BE systems (and vice versa) made between 33014 and 33223 are also invalid. /Now/ everything should be correct, though.

> Sorry for the trouble :-/

No, /I'm/ sorry for the trouble caused by my stupidity. I was too quick with changing the variables endianness, without properly checking all cases.

comment:9 by DrMcCoy, 11 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.