Opened 12 years ago

Closed 12 years ago

Last modified 23 months ago

#3786 closed defect (wontfix)

WINCE: CRUISE engine can not be compiled

Reported by: SF/lostech Owned by: SF/knakos
Priority: normal Component: Port: WinCE
Keywords: Cc:
Game:

Description

# ScummVM version ScummVM Version SVN 0.12.0 (actual checked out on 24.06.2008)

# Platform and Compiler (Win32, Linux, ...) Windows CE MSYS/cegcc

# Bug details, including instructions on reproducing The CRUISE and DRASCULA engines can not be compiled due to compiling errors. See log files for more detailed error output.

Ticket imported from: #2001583. Ticket imported from: bugs/3786.

Attachments (2)

compile_error_cruise.txt (1.1 KB ) - added by SF/lostech 12 years ago.
Error output during compiling for CRUISE engine
compile_error_drascula.txt (1.2 KB ) - added by SF/lostech 12 years ago.
Error output during compiling for DRASCULA engine

Download all attachments as: .zip

Change History (11)

by SF/lostech, 12 years ago

Attachment: compile_error_cruise.txt added

Error output during compiling for CRUISE engine

by SF/lostech, 12 years ago

Attachment: compile_error_drascula.txt added

Error output during compiling for DRASCULA engine

comment:1 by SF/lostech, 12 years ago

File Added: compile_error_drascula.txt

comment:2 by bluegr, 12 years ago

Can you please try compiling the drascula engine again? I've made some changes to it which should hopefully allow you to compile it correctly

comment:3 by SF/lostech, 12 years ago

I tried the DRASCULA engine compile again and both static and plugin compile did succeed now without compiling errors. THX.

comment:4 by bluegr, 12 years ago

Good, I'll rename the bug report then, as only the CRUISE engine is problematic now

comment:5 by bluegr, 12 years ago

Summary: WINCE: CRUISE and DRASCULA engines can not be compiledWINCE: CRUISE engine can not be compiled

comment:6 by SF/knakos, 12 years ago

Owner: set to SF/knakos
Resolution: wontfix
Status: newclosed

comment:7 by SF/knakos, 12 years ago

Currently, the cruise engine is not in a portable format (hence disabled by default). I cannot look at the attached build report right now (something's up with sf), but I've added a fixme in the codebase for including assert.h. The biggest problem is the direct fopen stuff in volume.cpp, which has a big FIXME on top of it so it will get fixed by the engine author.

I'll be closing this one; this stuff is handled by the engine author & they are apparent (no need for the bug report to remind him of these) through the fixmes.

comment:8 by SF/lostech, 12 years ago

OK, I thought it had to compile because I assumed that the basic engine structure is the same for all engines and therefore porable. Didn´t know that this isn´t the case.

comment:9 by digitall, 23 months ago

Component: Port: WinCE
Note: See TracTickets for help on using tickets.