Opened 11 years ago

Closed 10 years ago

#3787 closed defect (invalid)

SAM: Save game error

Reported by: SF/tuffylover Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

I am using the latest version 0.11.1, every time I save the game, the program stops responding (the picture freezes none of the controls work, only way out is to crtl-alt-delete and manually shut down the process). When I restart the game I can open the F5 menu but the moment I click on load it crashes to the desktop. I have the English Talkie CD-ROM, MS-DOS version. It also apparently didn't create a save game directory so I cannot upload a saved game.

Ticket imported from: #2001947. Ticket imported from: bugs/3787.

Attachments (1)

samnmax.s01 (26.4 KB) - added by SF/tuffylover 11 years ago.
Finally it saved!

Download all attachments as: .zip

Change History (29)

comment:1 Changed 11 years ago by fingolfin

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 Changed 11 years ago by fingolfin

Summary: Save game errorSAM: Save game error

comment:3 Changed 11 years ago by SF/tuffylover

0.11.1
every time I save the game, the
program stops responding (the picture freezes none of the controls work,
only way out is to crtl-alt-delete and manually shut down the process)
When I restart the game I can open the F5 menu but the moment I click on
load it crashes to the desktop.
I have the English version
Talkie CD-ROM, MS-DOS version
It also apparently didn't create a save game directory so I cannot
upload a saved game.

comment:4 Changed 11 years ago by fingolfin

You still didn't tell us your OS / platform :)

comment:5 Changed 11 years ago by SF/tuffylover

I have Windows XP.

comment:6 Changed 11 years ago by sev-

Please, follow our FAQ #5.6 in order to provide error message you get.

comment:7 Changed 11 years ago by SF/tuffylover

The "black screen of death" occurs whenever I try to load a saved game. The FAQ 5.6 doesn't tell me what to input after I get an old style dos box to appear. This is what I input. E:\C:\Program Files\ScummVM\scummvm.exe

comment:8 Changed 11 years ago by bluegr

Is the save path set correctly in ScummVM's options?

comment:9 Changed 11 years ago by sev-

tuffylover, please, provide one of the problematic saves.

comment:10 Changed 11 years ago by sev-

Status: newpending

comment:11 Changed 11 years ago by SF/sf-robot

Status: pendingclosed

comment:12 Changed 11 years ago by SF/sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:13 Changed 11 years ago by SF/tuffylover

Status: closednew

comment:14 Changed 11 years ago by SF/tuffylover

I can no longer even save. The program now crashes now every time I attempt it.

comment:15 Changed 11 years ago by fingolfin

Please tell us:
* Is your savepath set correctly?
* Can you please launch it from a consoe window, then tell us whether it prints any message there just before crashing?

comment:16 Changed 11 years ago by SF/tuffylover

My save game path is set correctly. I cannot use the dos box as it says one of two things "cannot find path" or not a legitimate bath or exe file.

comment:17 Changed 11 years ago by fingolfin

Owner: set to Kirben

comment:18 Changed 11 years ago by fingolfin

How exactly did you determine that your savepath is correct?

To run ScummVM from a console window, you have to specify the path to ScummVM, naturally... So don't just type
scummvm
but rather something like

C:\PROGRAMS\SCUMMVM\SCUMMVM.EXE

or wherever you have ScummVM installed... Maybe Kirben can give you a better hint as to what to do, he knows all about ScummVM on Windows ;)

Changed 11 years ago by SF/tuffylover

Attachment: samnmax.s01 added

Finally it saved!

comment:19 Changed 11 years ago by SF/tuffylover

I rematched both of the save game paths, the primary game path and selected the Windows platform instead of default now I can save! But now it refuses to load. Every time I click load the game crashes to desktop.
File Added: samnmax.s01

comment:20 Changed 11 years ago by sev-

What is the status of this item?

comment:21 Changed 11 years ago by Kirben

Owner: Kirben deleted

comment:22 Changed 10 years ago by eriktorbjorn

For whatever it's worth, I have no problem loading that savegame on my Linux box. Strange.

comment:23 Changed 10 years ago by SF/tuffylover

I am still waiting for some help concerning this problem. Though with school, I have actually forgotten that I own Sam and Max. Any assistance with this would be appreciated.

comment:24 Changed 10 years ago by fingolfin

Well, we can't reproduce your problem, it works for everybody else, even with your test game. So, I am afraid, there is relatively little we can do.

One last thing: Kirben, does the savegame work for you under Windows?

comment:25 Changed 10 years ago by fingolfin

Owner: set to Kirben

comment:26 Changed 10 years ago by Kirben

Yes, the attached saved game loads fine under Windows on my system.

I'm unable to reproduce the issues with saving in Sam and Max, even when manually setting the save game directory to location that isn't writable.

comment:27 Changed 10 years ago by Kirben

Owner: Kirben deleted

comment:28 Changed 10 years ago by sev-

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.