Opened 12 years ago

Closed 12 years ago

Last modified 17 months ago

#3778 closed defect (fixed)

ALL: broken --list-games

Reported by: SF/mit_service Owned by: jvprat
Priority: high Component: --Other--
Keywords: Cc:
Game:

Description

I just compiled from current svn and scummvm does not support any of my games anymore. Deleting and readding did not work.

scummvm --list-games yields the following output:

$ scummvm --list-games Using configuration file: /home/xxx/.scummvmrc Game ID Full Title ------------- --------------------------------------- $

If it matters: I am using linux.

Ticket imported from: #1996976. Ticket imported from: bugs/3778.

Change History (15)

comment:1 by fingolfin, 12 years ago

Summary: current svn does not support any gamesALL: --list-games reports empty list

comment:2 by fingolfin, 12 years ago

To process your bug report appropriately, we need you to provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build) * Bug details, including instructions on reproducing it * Language of game (English, German, ...) * Version of game (talkie, floppy, ...) * Platform and Compiler (Win32, Linux, MacOS, ...) * Attach a save game if possible * If this bug only occurred recently, please note the last version without the bug, and the first version including the bug. That way we can fix it quicker by looking at the changes made.

This should only take you a little time but will make it much easier for us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 by fingolfin, 12 years ago

Works great over here...

comment:4 by sev-, 12 years ago

In fact, we have just --list-games broken. Trying to narrow it down...

comment:5 by sev-, 12 years ago

Priority: normalhigh
Summary: ALL: --list-games reports empty listALL: broken --list-games

comment:6 by fingolfin, 12 years ago

Owner: set to jvprat

comment:7 by fingolfin, 12 years ago

It still works fine over here.

Is it possible that both of you are building with plugins enabled? Then this would explain why things don't work for you, because the engine manager is not initialized at the point "--list-games" executes (so this regression was introduced by Jordi & my changes there).

comment:8 by fingolfin, 12 years ago

In particular, try changing PluginManager::instance().loadPlugins(); to PluginManager::instance().loadPlugins(); EngineMan.getPlugins(); in base/main.cpp -- does that help?

comment:9 by SF/mit_service, 12 years ago

I did a compile on another system and it works there - seems to be dependency/system related. working on Ubuntu 8.04 not working on a current gentoo install Both times i did just a plain ./configure, so no plugins enabled. As soon as I am back at my gentoo box I'll do some aditional testing.

comment:10 by jvprat, 12 years ago

I've tried it with a clean SVN checkout with both plugins and builtin engines and I can't reproduce it (also on gentoo). Can you give more details?

comment:11 by fingolfin, 12 years ago

Note: My earlier believe that EngineMan may not have been inited is of course bogus. Since you also said that static plugins were used, I have no idea what else might cause it :/

comment:12 by SF/mit_service, 12 years ago

Ok, all was my fault. Aparently make clean is not enough to clean the sourcedir. I deleted everything except the .svn dir and did a fresh svn update. After that scummvm and --list-games was working again. Sorry for the noise.

comment:13 by SF/mit_service, 12 years ago

The issue is resolved for me. Closing...

comment:14 by SF/mit_service, 12 years ago

Resolution: fixed
Status: newclosed

comment:15 by digitall, 17 months ago

Component: --Unset----Other--
Note: See TracTickets for help on using tickets.