Opened 11 years ago

Closed 10 years ago

#3749 closed defect (fixed)

WOODRUFF: Game is dead on the Rummy's "Game Over"

Reported by: SF/radioactiveg Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Woodruff

Description

* ScummVM 0.12.0 svn (27.5.08)
* English

When you play Rummy with the jail guards at the Jail Yard, after several times the guards call you back to play (or if you stay too long?), the game is supposed to end with a "Game Over" title screen, and then I think it restarts. [save file is attached]
In this version of ScummVm (the times I tried) the screen is darkened and the game gets stuck (music still plays) when the "Game Over" should appear.

Furthermore, when rerunning Woodruff and trying to load any game save, the game is crushed and shut down after the loading screen.

Only reinstallation of ScummVm solved that problem.

Ticket imported from: #1974745. Ticket imported from: bugs/3749.

Attachments (1)

woodruff-gb.s05 (16.3 KB) - added by SF/radioactiveg 11 years ago.
Save Game - Woodruff at the Jail Yard after been called twice back to the Rummy table.

Download all attachments as: .zip

Change History (15)

Changed 11 years ago by SF/radioactiveg

Attachment: woodruff-gb.s05 added

Save Game - Woodruff at the Jail Yard after been called twice back to the Rummy table.

comment:1 Changed 11 years ago by SF/radioactiveg

Owner: set to DrMcCoy

comment:2 Changed 11 years ago by DrMcCoy

Hmm, yes, the scripts call a "6.tot" there, which doesn't exist (no idea why, yet).

But what do you mean with the second and third paragraph?
Do you mean that the same save games start working again after reinstalling ScummVM? Because I have no idea how that would work.
Does saving and loading work for you in general? How does a crash look like, is something written in the console? Which game version and which OS do you run?

comment:3 Changed 11 years ago by SF/radioactiveg

I just want to add in case that it wasn't obvious, that in the original game there IS an Game Over titled screen then.

I mean that after it happens (the black screen which goes on with the music played), when I shut ScummVm down and run Woodruff again, every loading of any save made ScummVm to shut down immediately after the short loading screen. No error was given, just closing the program. and so on and so forth.
Only when I installed ScummVm 0.12.0 svn again, loading saved games was back to work again.

[Irrelevant question: bugs that certainly occurred in the original game are welcome to be reported? Such as paradox occurrences?]

comment:4 Changed 11 years ago by DrMcCoy

Yes, the "6.tot" is probably a bug somewhere, or a value that gets substituted in the original code.

About the save games:
The _same_ save games, that didn't work earlier, load again after reinstalling ScummVM?
I _really_ can't see how that works. Either the save is corrupt, in which case no reinstalling can bring it back to live, or it's not, in which case at most a simple restart of ScummVM should be enough. There is _no way_ it can "taint" an installation. Also, here on my end at least, I don't see any access to save files in that place at all.
o_O

[Depends on what you mean. If it's something complex in the specific game logic, then it's in the scripts and I have no chance to change that.]

comment:5 Changed 11 years ago by SF/radioactiveg

I'll try to explain myself again (Sorry for the poor language skills...), first by asking you:
After it happens to you, all you can do is to close ScummVm. Right?
Can you load saved games normally afterwards? Everything is ordinary by you?

I mean, with me, after that phenomena EVERY LOAD of any of ALL the save files (that of course worked fine before the phenomena) ends up with ScummVm being shut down.

comment:6 Changed 11 years ago by DrMcCoy

Yes, ScummVM closes itself after a click. Then, when I restart ScummVM, I can load all save games normally.

After you reinstall ScummVM, do you create new save games, or do you load the old ones again?

comment:7 Changed 11 years ago by SF/radioactiveg

Well that's pretty embarrassing...
Somehow it doesn't happen anymore (I swear I repeated this dozens of times). The loading is function again afterwards.
Now it happens exactly the way you describe it: ScummVM closes itself after a click. But as the way I remember it, it didn't close itself after a click before when it happened and I needed to shut it down manually. Strange.

I'm talking about the same save games.

comment:8 Changed 11 years ago by DrMcCoy

Strange. As I said, I really don't understand how that would be possible. Oh well...

comment:9 Changed 11 years ago by fingolfin

Could it be that the original exe, when it detects that script "6.tot" is to be loaded, loads some other script instead? If the original .exe is not compressed or obfuscated in some way, it might be trivial to check that (i.e. using "strings" on the file + grep ;).

comment:10 Changed 11 years ago by DrMcCoy

Unfortunately, no. ;)

comment:11 Changed 10 years ago by sev-

What is the status of this item?

comment:12 Changed 10 years ago by DrMcCoy

That bug still appears.

comment:13 Changed 10 years ago by DrMcCoy

Okay, I still don't know why the bug appears in the first place (or whether it also happens in the original), but I've found a workaround.

comment:14 Changed 10 years ago by DrMcCoy

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.