Opened 12 years ago

Closed 12 years ago

#3747 closed defect (fixed)

DIG: Subtitle glitch (Regression)

Reported by: lordhoto Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

ScummVM 0.12.0svn (May 26 2008 14:08:31) Features compiled in: Vorbis FLAC MP3 ALSA zLib MPEG2 Platform: Linux Compiler: g++ (GCC) 4.2.4 (Debian 4.2.4-1) Game: The Dig, English and German, DOS CD

When first talking to Miles through the Comm, the lines saying "You wish."/"Hättest du wohl gerne." and "In your dreams"/"In Deinen Träumen" are drawn three times and also speech is missing. Also for the line "In Deinen Träumen" in the German Version "In your dreams" is displayed.

How to reproduce it: Start a new Dig game, use the Pen Ultimate and launch the Comm and then talk to Miles.

I attached screenshots for the affected passages.

Ticket imported from: #1973247. Ticket imported from: bugs/3747.

Attachments (4)

dig_1.png (66.2 KB ) - added by lordhoto 12 years ago.
"You wish." (English)
dig_2.png (66.6 KB ) - added by lordhoto 12 years ago.
"In your dreams" (English)
dig_3.png (66.6 KB ) - added by lordhoto 12 years ago.
"You wish" (German)
dig_4.png (66.7 KB ) - added by lordhoto 12 years ago.
"In your dreams" (German)

Download all attachments as: .zip

Change History (19)

by lordhoto, 12 years ago

Attachment: dig_1.png added

"You wish." (English)

by lordhoto, 12 years ago

Attachment: dig_2.png added

"In your dreams" (English)

comment:1 by lordhoto, 12 years ago

File Added: dig_2.png

comment:2 by lordhoto, 12 years ago

File Added: dig_3.png

by lordhoto, 12 years ago

Attachment: dig_3.png added

"You wish" (German)

comment:3 by lordhoto, 12 years ago

File Added: dig_3.png

by lordhoto, 12 years ago

Attachment: dig_4.png added

"In your dreams" (German)

comment:4 by lordhoto, 12 years ago

File Added: dig_4.png

comment:5 by Kirben, 12 years ago

Owner: set to Kirben

comment:6 by eriktorbjorn, 12 years ago

That has to be a regression, right? At least, I'm pretty sure it used to work fine. If so, I might take a look later today, to try and figure out when it broke.

comment:7 by eriktorbjorn, 12 years ago

It worked in 0.11.1.

comment:8 by eriktorbjorn, 12 years ago

The problem appears to have been introduced in revision 31782, "Add extra hard coded strings translations, from second release of The Dig." If I comment out the following lines from ScummEngine_v7::translateText() ...

else if (!strcmp((const char *)text, "/NEWTON.032/")) text = (const byte *)"/NEW.11/You wish."; else if (!strcmp((const char *)text, "/NEWTON.034/")) text = (const byte *)"/NEW.12/In your dreams";

... it works again for me.

comment:9 by Kirben, 12 years ago

Yes, I know that is the trigger point for this bug. Those changes were based off the updated version of The Dig, which altered a lot of the subtitle related code.

The English string is been shown, since those hard code translations should actually be '/NEW.011/' and '/NEW.012/'.

But that actual problem is the prefix tag should be unchanged for speech, with the hard coded string changes only applying to the subtitle option.

comment:10 by Kirben, 12 years ago

The missing speech and untranslated subtitle should be fixed now.

I'm not sure about the three lines of subtitles though, see script 252. Two lines are drawn by kernelSetFunctions.enqueueTextCentered[] and one line via regular subtitles (due to the hard coded string translations).

When I run the original updated version of The Dig (DOS or Windows), I'm unable to get any subtitles for the 'You wish.' and 'In your dreams.' segments.

comment:11 by lordhoto, 12 years ago

Sound is working now again, though in the English version of the Dig now there are two voices, exactly with the same text, (one from Miles and another one from Low) played at the same time in those two passages (maybe it's supposed to be like that in original? Never played it without ScummVM, I might give it a try to check though).

Also in the German version now the first (as in top most) subtitle appearing is translated correctly, the second and third are now English though. The first "Hättest du wohl gerne." seems to be centered now too. And only one voice (from Miles) in those two passages in German. I can attach screenshots if needed.

comment:12 by Kirben, 12 years ago

Yes, it is normal for Low and Miles to say the 'You wish.' and 'In your dreams.' segments together.

comment:13 by lordhoto, 12 years ago

Oh and I noticed a very minor difference between the first and the other two subtitles in the "In your dreams" passage, the first lacks a '.' at the end, while the other two have it.

comment:14 by Kirben, 12 years ago

In the updated release of The Dig I wonder if they were trying to replace the subtitles through 'kernelSetFunctions.enqueueTextCentered[]' by regular subtitles, for some reason.

Anyway I'm reverting the two lines that are triggering this problem, as they seem to offer no advantage, at least under ScummVM.

comment:15 by Kirben, 12 years ago

Resolution: fixed
Status: newclosed
Summary: DIG: Subtitle glitchDIG: Subtitle glitch (Regression)
Note: See TracTickets for help on using tickets.