Opened 11 years ago

Closed 11 years ago

#3738 closed defect (fixed)

BLUESABCTIME: crash

Reported by: SF/islanti Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Blue's ABC Time Activities

Description

Blue's ABC Time English CD crashes after entering the player's name. This happens with 0.11.1 and a recent 0.12 daily build. Videos have been converted to DXA and are working in engine before the crash. No errors are reported withthe video.

The --debuglevel=10 output leading up to the crash:
findResource(AKCI, 50b5a7c)
findResource(AKSQ, 50b5a7c)
findResource(AKCD, 50b5a7c)
findResource(AKPL, 50b5a7c)
findResource(AKCT, 50b5a7c)
getResourceAddress(Matrix,2) == NULL
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Buffer,9) == 0p43c1bac
getResourceAddress(Costume,8) == 0p50b5a7c
findResource(AKSQ, 50b5a7c)
findResource(AKFO, 50b5a7c)
(5:11:0x1A486): getResourceAddress(Script,11) == 0p20f1efc
(5:11:0x2F9): Script 11, offset 0x2f9: [73] o6_jump()
(5:11:0x9): Script 11, offset 0x9: [3] o6_pushWordVar()
(5:11:0xB): readvar(19)
(5:11:0xB): push 0
(5:11:0xC): Script 11, offset 0xc: [0] o6_pushByte()
(5:11:0xD): push 0
(5:11:0xE): Script 11, offset 0xe: [10] o6_gt()
(5:11:0xE): pop 0
(5:11:0xE): pop 0
(5:11:0xE): push 0
(5:11:0xF): Script 11, offset 0xf: [5D] o6_ifNot()
(5:11:0xF): pop 0
(5:11:0x2F8): Script 11, offset 0x2f8: [6C] o6_breakHere()
(5:208:0x2F8): getResourceAddress(Room,5) == 0p50e57e4
(5:208:0x18F5E): Script 208, offset 0x18f5e: [73] o6_jump()
(5:208:0x18F56): Script 208, offset 0x18f56: [0] o6_pushByte()
(5:208:0x18F57): push 22
(5:208:0x18F58): Script 208, offset 0x18f58: [98] o6_isSoundRunning()
(5:208:0x18F58): pop 22

At this point the SCUMMVM process stops responding according to Windows.

Ticket imported from: #1971331. Ticket imported from: bugs/3738.

Change History (9)

comment:1 by SF/islanti, 11 years ago

Same files work fine with SCUMMVM WinCE port, so this issue seems to be Win32 (Vista) specific.

comment:2 by SF/islanti, 11 years ago

Clarification. With Win32 on Vista the game crashes 100% of the time as described in this bug.

WinCE version crashes if any names exist in the "chalkboard" user selection screen. Deleting all names and creating a new one works fine as a workaround in WinCE at least.

comment:3 by fingolfin, 11 years ago

Kirben, any comments on this?

comment:4 by fingolfin, 11 years ago

Owner: set to Kirben
Summary: bluesabctime crashBLUESABCTIME: crash

comment:5 by Kirben, 11 years ago

Owner: Kirben removed

comment:6 by Kirben, 11 years ago

Not sure what could trigger a lock up when checking whether sound is still running. I suspect the actual lock up point could be in a different area of code.

But I don't own any of the Blue's Clues games, so can't do any further testing.

comment:7 by SF/islanti, 11 years ago

Is there any additional testing I can do to provide more/better information?

comment:8 by Kirben, 11 years ago

Component: Engine: SCUMM
Game: Blue's ABC Time Activities
Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:9 by Kirben, 11 years ago

The crash was caused by memory corruption, due to several invalid writes in wizPackType1(). The crash is fixed in ScummVM SVN, use the next daily snapshot of ScummVM SVN.

Note: See TracTickets for help on using tickets.