Opened 11 years ago

Closed 9 years ago

#3735 closed defect (fixed)

IHNM: Psychic Profile problem

Reported by: Kirben Owned by: sev-
Priority: high Component: Engine: SAGA
Keywords: Cc:
Game: I Have No Mouth

Description

ScummVM 0.12.0svn (May 23 2008 16:31:30)
Compiled under mingw with GCC 4.2.1-dw2
Running on Windows XP Media Center 2005 Edition
English DOS version I Have No Mouth, and I Must Scream

When the Psychic Profile is two pages, it is possible to exit the profile (via mouse click), after viewing only the first page. If the game is left idle, the second page of psychic profile will still be shown, after a short delay.

For example, after eating the forbidden fruit when playing Benny. Check the psychic profile and exit (via mouse click) after the first page.

A saved game is attached, just use the Psychic Profile and exit (via mouse click) after the first page is displayed.

Ticket imported from: #1970191. Ticket imported from: bugs/3735.

Attachments (1)

ihnm.s01 (663 bytes ) - added by Kirben 11 years ago.
Saved Game

Download all attachments as: .zip

Change History (13)

by Kirben, 11 years ago

Attachment: ihnm.s01 added

Saved Game

comment:1 by bluegr, 11 years ago

Hm, I didn't know that it was possible to have more than one page in the psychic profile - it's one page in most scenes, hence the problem that you mention here...

comment:2 by sev-, 11 years ago

Raising priority. This bug is nice to get fixed before the release.

comment:3 by sev-, 11 years ago

Owner: set to bluegr
Priority: normalhigh

comment:4 by bluegr, 11 years ago

Resolution: fixed
Status: newclosed

comment:5 by bluegr, 11 years ago

The psychic profile only has 1 page

The problem was that the thread that closed the psychic profile was waiting for no reason

Fixed in the latest SVN version, closing

comment:6 by Kirben, 11 years ago

The problem still occurs, with current ScummVM SVN.

The Psychic Profile should be two pages long in this case, although it is only shown one page at a time.

Do you want screenshots from the original game?

comment:7 by Kirben, 11 years ago

Resolution: fixed
Status: closednew

comment:8 by bluegr, 11 years ago

I opened the psychic profile before eating the fruit with Benny, that's why I only saw 1 page. Eating the fruit and then opening the psychic profile shows 2 pages indeed. The problem is that the opcode that's clearing the psychic profile should move on to the next page in this case instead of closing the profile.

I don't want screenshots, thanks, I have several versions/languages of the original game.

comment:9 by fingolfin, 10 years ago

What is the status of this item?

comment:10 by Kirben, 10 years ago

Unchanged, the problem still occurs.

comment:11 by sev-, 9 years ago

Owner: changed from bluegr to sev-
Resolution: fixed
Status: newclosed

comment:12 by sev-, 9 years ago

Fixed. Still there is a problem with double fade, but is much better

Note: See TracTickets for help on using tickets.