Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3733 closed defect (fixed)

WOODRUFF: Ego does not act

Reported by: raziel- Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Woodruff

Description

ScummVM 0.12.0svn (May 23 2008 05:05:15) Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Ego is "stuck" in front of Azimuth's house. The only thing one can do is click on the house to make ego walk inside, look around and leave again (automatically).

Nothing else works, like clicking on objects, NPC's, not even trying to switch screens by using the "opening door" icon.

The Bizarre Adventures of Woodruff and the Schnibble (DOS/English (GB))

AmigaOS4 gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1970112. Ticket imported from: bugs/3733.

Attachments (1)

WoodruffGoblinDebug.patch (968 bytes ) - added by DrMcCoy 12 years ago.
Some walking code debug output

Download all attachments as: .zip

Change History (12)

comment:1 by sev-, 12 years ago

Component: --Unset--Engine: Gob
Game: Woodruff
Owner: set to DrMcCoy

comment:2 by DrMcCoy, 12 years ago

Hmm, that's really bad. I can't reproduce that here, so it's probably a signess or endianness issue. :/

comment:3 by DrMcCoy, 12 years ago

Woodruff should now be controlable in the SVN repo (it was an endian-issue when loading the map walkmeshes). It's still breaks when switching screens, though. And object videos are mispositioned.

comment:4 by DrMcCoy, 12 years ago

Okay, the scripts in Woodruff just assume way to much about how variables are stored. Woodruff really expects them to be stored in little endian, and the current approach (storing them in native endianness), just doesn't work here.

So, I think I'll completely change variable storing, always putting them in the endianness of the original game (i.e. for PC games, store them always in little endian and for Amiga and Mac games, store them always in big endian). That would take care of any endianness related issues with the variables.

comment:5 by DrMcCoy, 12 years ago

Could you retry with the current SVN code? I've just checked in the variable endianess change.

comment:6 by raziel-, 12 years ago

Sorry. EGO still does not act, he just stands there. EGO won't enter Azimuth's house no more, aswell Clicking on objects or characters doesn't do anything

comment:7 by DrMcCoy, 12 years ago

Hmm, crap. :/ It does work for my in qemu-ppc (really slow, of course), so I can't even reproduce it anymore. :/

by DrMcCoy, 12 years ago

Attachment: WoodruffGoblinDebug.patch added

Some walking code debug output

comment:8 by DrMcCoy, 12 years ago

Hmm, could you apply this patch, then run Woodruff, click on free place on the streets and tell me what appear in stderr (as a "WARNING:")? File Added: WoodruffGoblinDebug.patch

comment:9 by raziel-, 12 years ago

Seemed to be another faulty build on my side. It worked after your patch, which was kind of strange. Rebuilding the whole thing afterwards fixed it.

Sorry for confusion and for the extra work :-/

comment:10 by DrMcCoy, 12 years ago

k, so I'm closing this as fixed then. :)

comment:11 by DrMcCoy, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.