Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3723 closed defect (invalid)

KYRA3: Crash when loading

Reported by: SF/darktree Owned by: lordhoto
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 3

Description

ScummVM immediatly closes when I load Kyrandia 3: Malcoms Revenge.

I am using v. 0.12 SVN May 14th build on Windows vista. The Win32 installer.

I chose the MALCOM folder directory in the ScummVM interface and chose the English version. Upon hitting start, SvummVM just completely closes, and Windows doesn't even recognize it as a crash. No report tries to even notify me.

It seems no one else is having this problem though. Also, the HOF_CD (demo) that is on the Kyrandia 3 CD works just fine. And I have played through the full version of Kyrandia 2, and it played through relatively fine. I can't even get to an intro video or anything before Malcom's Revenge even begins.

Ticket imported from: #1963711. Ticket imported from: bugs/3723.

Change History (7)

comment:1 by fingolfin, 12 years ago

Owner: set to lordhoto
Summary: CrashKYRA3: Crash when loading

comment:2 by fingolfin, 12 years ago

That Windows didn't "recognize" it as a crash usually means that it didn't crash, but rather performed a controlled abort (I know, for non-programmers this is a rather too subtle distinction ;-). Anyway, likely ScummVM prints out some error messages to the console which might help figure out what goes wrong. Not being a Windows user, though, I am not sure how to read those. Maybe you can start ScummVM from a shell (cmd.exe on Windows, I believe) ?

comment:3 by SF/darktree, 12 years ago

Wow hey I got it fixed! Thanks! I DO understand the difference between a controlled abort and an out an out crash, but being as that I just finished .NET 101 and SQL 101.... well lets say I'm just starting to get the hang of this gaming programming stuff ;)

Anyway, your followup really helped. Turns out you were right on the money for a lot of it. It was a controlled abort, hence the strange "no crash" symptoms. ScummVM did indeed 'print' out some console messages a split second before it closed itself, but unfortunately it didn't write to any log file I could find. I had to be quick with my trigger finger to hit the prntscrn button why the program was closing itself to read what the messages were before they vanished into my desktop. In so many words it read:

"Missing file AUD.PAK"

..a file not found on the disc or available through ScummVM. However, when you install the game normally through the CD's setup, it installs this file, and numerous other unique and necessary .pak files into the directory of your choice. This poses a problem. If I choose my cd installed directory through ScummVM, it does not recognize the game. But if I choose the CD-Rom as the directory, it is missing those files. And I obviously cannot copy the files I need from the CD installed directory, back into the CD rom /MALCOM/ directory. The answer? Here is what I did:

Tried to copy all the files from the CD to my Hard drive into a new desktop folder I named kyrandia3. That folder would act as a sort of fake cd directory. That doesn't work thanks to DRM. So I load up a decrypter program to rip all the entire CD's raw files to the kyrandia3 folder (on my desktop) bypassing the DRM. Then, copy the necessary installed directory contents (c/programfiles/westwood/malcom) on top of the CD's .pak/.exe/.aud files into my kyrandia3's folder on my desktop. Now with the combined files from the original CD, and then the installed files from my C drive, I have a working 3rd directory with all of the game data ScummVM needs to play Kyrandia 3: Malcom's Revenge!

Game starts, plays intro, goes to menu, and seemingly speech and sound all are working up to this point. Hopefully it will be a smooth enough ride to the end!

comment:4 by lordhoto, 12 years ago

Next time you should really read our datafiles page first, as mentioned in the news item. Check here: http://wiki.scummvm.org/index.php/Datafiles#Legend_of_Kyrandia.2C_The:_Malcolm.27s_Revenge it mentions "WESTWOOD.001" which contains AUD.PAK. I'm marking this one as invalid then. About your 'solution': what the hack is that stuff about DRM? You can simply copy over all files listed on that page in a single directory and point ScummVM to it.

comment:5 by lordhoto, 12 years ago

Resolution: invalid
Status: newclosed

comment:6 by SF/darktree, 12 years ago

I did indeed check the required datafiles for this game prior to posting. I must have misunderstood. I had some of them, but I did not know I was missing any until I ran it. I had the WESTWOOD.001 file, and some of the other required files, but not all of them. Sorry if this was an "invalid" question, but it was a very valid question for me, as this was not easily ran without some messing around first thst wasn't initially explained.

As for the bit about drm, I just assumed it had some sort of security built into the cd as Windows wasn't letting me copy from the CD without having to do some special operations. I'm really really unhappy with Vista at the moment. It was in my understanding I had to manually "hack" the files off the CD as Windows wasn't letting me for some reason.

Thanks for your help, lordhoto. I should try not dealing with this stuff at 5 in the morning from now on.

comment:7 by lordhoto, 12 years ago

There is no messing around with the things, you were talking about here, required to run the game, so it *is* invalid and thus doesn't really belong on our bug tracker. If you got questions on how to do things, you should check the README, wiki and last but not least forums and ask there if it wasn't asked there allready, instead of posting a bug.

Note: See TracTickets for help on using tickets.