Opened 11 years ago

Closed 11 years ago

#3724 closed defect (invalid)

WIN CE, COMI: Crash in the difficulty selector

Reported by: SF/janne_petman Owned by: SF/knakos
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

I get a crash after selecting difficulty in COMI. The sound works just fine, dagger flies into the board and after that it crashes all the way to desktop. I am using A HTC S730 with Windows Mobile 6 Standard (non-touchscreen device). Tried both compressed and uncompressed games and confirmed the data files are intact. HTC early rom quirkiness? :)

(Tried to debug this yesterday with the #scummvm ppl to no avail. I am eager to try a new snapshot for the Win CE if you are still actively developing it.)

Ticket imported from: #1964292. Ticket imported from: bugs/3724.

Change History (9)

comment:1 by SF/janne_petman, 11 years ago

Summary: Crash in the difficulty selectorWIN CE, COMI: Crash in the difficulty selector

comment:2 by SF/janne_petman, 11 years ago

The build I used was 0.11.1 version

comment:3 by fingolfin, 11 years ago

Owner: set to SF/knakos

comment:4 by SF/knakos, 11 years ago

please attach a savegame file nearby so I can check for this crash.

comment:5 by Kirben, 11 years ago

The problem is reported in the level selection screen at the start of COMI, surely you don't need a saved game?

comment:6 by SF/knakos, 11 years ago

Priority: normallow

comment:7 by SF/knakos, 11 years ago

oh, heh. Guess who didn't had coffee before reading the bug report :-S

This must be free memory size related. After the dagger screen, a couple more megs are needed (allocated) to play the intro. Lowering priority until I confirm this.

comment:8 by SF/knakos, 11 years ago

Resolution: invalid
Status: newclosed

comment:9 by SF/knakos, 11 years ago

(whoops, old bug report :-) )

Yep, COMI runs just fine, but the executable size increase causes these faults with lower end devices.

Note: See TracTickets for help on using tickets.