Opened 12 years ago

Closed 12 years ago

#3691 closed defect (fixed)

SQ2: Text prompt glitch

Reported by: eriktorbjorn Owned by: bluegr
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Space Quest 2

Description

Current SVN snapshot English version of the game

I guess this is actually two separate bugs, but...

Near the end of the game, you're supposed to enter a code to abort the clone launch. On this screen, the game does not draw any text prompt. If I hit Enter, the game draws a "-" prompt. I think the prompt is actually supposed to be "-->". At least, that's what _game.strings[0] contains.

I haven't verified this with the original interpreter. I thought I saw a screenshot somewhere that showed the full prompt, but I can't remember where.

Ticket imported from: #1939632. Ticket imported from: bugs/3691.

Attachments (1)

sq2.021 (1.3 KB ) - added by eriktorbjorn 12 years ago.
Examine the screen to see the glitch

Download all attachments as: .zip

Change History (6)

by eriktorbjorn, 12 years ago

Attachment: sq2.021 added

Examine the screen to see the glitch

comment:1 by sev-, 12 years ago

Owner: set to bluegr

comment:2 by SF/buddha_, 12 years ago

This looks very similar to the bug #1875076 "AGI GR: Input prompt not changing in outhouse" although from a different game, of course.

comment:3 by bluegr, 12 years ago

What buddha_ said is correct, the bugs in the two bug reports are actually caused by incorrect handling of nonstandard text input prompts. I've fixed this partially with commit #31477, however it seems that the text prompt is not correctly updated sometimes - currently, it's updated when the prompt changes and there is already a prompt on screen, which is not the correct way of updating it

comment:4 by bluegr, 12 years ago

Resolution: fixed
Status: newclosed

comment:5 by bluegr, 12 years ago

Fixed in the latest SVN (revisions #31477 and #31485). Closing

Note: See TracTickets for help on using tickets.