Opened 11 years ago

Closed 11 years ago

#3668 closed defect (fixed)

DIG: Subtitle speed affects speech when subtitles are off

Reported by: SF/ikorb Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

Version: ScummVM 0.11.1 (Feb 24 2008 12:46:21)
Game version: PC MS-Dos CD, english
Platform: Win32, official binary
Affected versions: lower limit not known, still present in daily build

The "subtitle speed" setting in the options causes pauses between speech samples in The Dig even when subtitles are disabled.

Steps to reproduce:
- delete SCUMMVM.INI
- start ScummVm, add The Dig to the games.
- Select Options->Audio, set Subtitle speed to 255. Notice that the "Text and speech" field defaults to "Speech only".
- Select Ok, then Start
- Watch the intro movie or skip it with Escape
- Right click to get the inventory, select the Pen Ultimate PDA (second from the left)
- click the Comm icon (right)
- click on Miles (lower right)
- Notice that there are long pauses between the dialog lines where the speech animation continues, even though there are no subtitles displayed.

The pauses disappear when the Subtitle speed is set to 0.

Expected result: The subtitle speed should not affect the speech sample playback when the subtitles are disabled.

Ticket imported from: #1925322. Ticket imported from: bugs/3668.

Change History (5)

comment:1 by Kirben, 11 years ago

This problem, would be due to the current code for processSfxQueues() not matching the disassembly of The Dig.

Also I noticed that _mouthSyncTimes isn't currently set at all for The Dig under ScummVM, although it still seems to be used by the original code, judging by disassembly.

comment:2 by Kirben, 11 years ago

Summary: Subtitle speed affects speech even when subtitles are offDIG: Subtitle speed affects speech when subtitles are off

comment:3 by dhewg, 11 years ago

I have a handful of reports of the same problem on COMI on the Wii port (rev 35709). Without knowing the engine code, is this related?

comment:4 by Kirben, 11 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:5 by Kirben, 11 years ago

When processSfxQueues() code was originally changed to ignore _talDelay, when only speech is used, I had to limit SCUMM versions it applied to (since iMuse digital failed to detect when speech stopped).

Fixed in ScummVM SVN, use the next snapshot of ScummVM SVN.

Note: See TracTickets for help on using tickets.