Opened 12 years ago

Closed 12 years ago

#3669 closed defect (fixed)

HoF: ScummVM quits on ESCaping "Virgin" and "Westwood" logo

Reported by: raziel- Owned by: athrxx
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 2

Description

ScummVM 0.12.0svn (Mar 26 2008 20:41:51) Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Pressing ESC (or the right mouse button) while the "Virgin" or "Westwood" logo is shown, makes ScummVM quit, instead of skipping to the next part.

The Legend of Kyrandia: Hand of Fate (English/CD)

AmigaOS4 gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1926532. Ticket imported from: bugs/3669.

Change History (9)

comment:1 by lordhoto, 12 years ago

All I can say is that I can not reproduce this. Florian please take a look at this.

comment:2 by lordhoto, 12 years ago

Owner: set to athrxx

comment:3 by athrxx, 12 years ago

I cannot reproduce this either. Right mouse button doesn't do anything for me. Esc key works the same way as left click. What does the engine do when you press the left mouse button? Does that bug occur with AmigaOS4 only? Or also with Windows?

comment:4 by raziel-, 12 years ago

You need to press ESC at least two times when the logos come up, one doesn't affect this behaviour, two or more times seem to trigger something.

The right mouse button also only works if used together with the left mouse button, so click right, click left, click right, click left triggers it...

comment:5 by athrxx, 12 years ago

Okay, I now actually could reproduce this. I comitted a fix for a similiar problem a few days ago (engine would quit after repeatedly pressing the left mouse button during the main menu animation and then selecting 'introduction'). I've just committed another fix. Please check this out...

comment:6 by athrxx, 12 years ago

Okay, I now actually could reproduce this. I comitted a fix for a similiar problem a few days ago (engine would quit after repeatedly pressing the left mouse button during the main menu animation and then selecting 'introduction'). I've just committed another fix. Please check this out...

comment:7 by raziel-, 12 years ago

Fixed in revision 31259

Thanks a lot

comment:8 by athrxx, 12 years ago

Resolution: fixed
Status: newclosed

comment:9 by athrxx, 12 years ago

Thanks for your report.

Note: See TracTickets for help on using tickets.