Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#3602 closed defect (fixed)

AGI: palette-related glitches reported.

Reported by: (none) Owned by: SF/buddha_
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: AGI Fanmade

Description

From Sev:

"There were palette-related glitches reported"

Robin Gravel

Ticket imported from: #1881170. Ticket imported from: bugs/3602.

Change History (14)

comment:1 by bluegr, 13 years ago

To process your bug report appropriately, we need you to provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build) * Bug details, including instructions on reproducing it * Language of game (English, German, ...) * Version of game (talkie, floppy, ...) * Platform and Compiler (Win32, Linux, MacOS, ...) * Attach a save game if possible * If this bug only occurred recently, please note the last version without the bug, and the first version including the bug. That way we can fix it quicker by looking at the changes made.

This should only take you a little time but will make it much easier for us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by (none), 13 years ago

I use scummvm 0.11.0 win32.

This agi palette glitches appear in Naturette 2, 3, Abrah l'orphelin de l'espace, Serguei's destiny 1.

Robin Gravel

comment:3 by SF/buddha_, 13 years ago

Could you please be more specific. What kind of palette glitches are you talking about?

comment:4 by SF/buddha_, 13 years ago

Component: Engine: AGI
Game: AGI Fanmade
Owner: set to SF/buddha_

comment:5 by (none), 13 years ago

I mean... the agi palettes don't work on Naturette 2, 3, ...

comment:6 by SF/buddha_, 13 years ago

I committed a fix for this bug to the trunk in revision 30708.

Please, Robin, could you verify that this bug is totally gone in all the games you mentioned and that the palettes really work just the way you meant for them to work in those games?

I'll close this bug when I get confirmation.

comment:7 by (none), 13 years ago

I'd like to try but where is it? I see no attach file here.

Robin Gravel

comment:8 by SF/buddha_, 13 years ago

Robin, If you're using Windows then just grab Win32 Daily Snapshot from the ScummVM's download page (At the bottom of the page). Link to the downloads page is http://www.scummvm.org/downloads.php and the direct link to the Win32 Daily Snapshot is http://scummvm.sourceforge.net/downloads/scummvmwin32.exe

If you're using Linux then grab a daily build from http://www.scummvm.org/daily/ from the "ia32/Linux"-column.

comment:9 by (none), 13 years ago

Hi Kari

First I got "WARNING: Invalid AGIPAL palette (Over 6 bits per color component) in 'pal.103'. Using only the lowest 6 bits per color component!" but it's not really a problem.

"Naturette 3, Serguei's destiny and Abrah" don't have any problems. The agipal works perfectly under ScummVm.

In Naturette 2, the palettes seen not to work but nothing else serious happens.

Jolimie (French of Serguei's destiny) has serious problems.

Nearby everything is black and the game freezes when the game begins.

Please check out at: http://www.atariage.com/forums/index.php?automodule=blog&blogid=56&showentry=4468

You will find a zip file with agi palette you have asked.

Robin Gravel

comment:10 by (none), 13 years ago

Ho yeah.

You will find the game at: http://membres.lycos.fr/agisite/jolimie.htm

Have fun

Robin Gravel

comment:11 by SF/buddha_, 13 years ago

Ok, Jolimie is probably a different bug so let's leave that out of this bug report for now. If you want you can file another bug report describing the problems with Jolimie (I tried running Jolimie myself too and yep, it hangs ScummVM before the intro begins so it is real bug).

But about Naturette 2, I tried running it under DOSBox 0.72 using the AGI.EXE that came with its zip-file and at least the starting image and the first two rooms look pretty much the same as in ScummVM. So how should the palettes work?

comment:12 by (none), 13 years ago

You are right about Naturette 2.

The agipal under ScummVm works well. I didn't pay attention. Sorry for that.

But in Jolimie, the screen is black when the game begins and like you said, the game freezes.

The game freezez is another problem but how about the black screen? Is it a bug related to agipal or something else?

Robin Gravel

comment:13 by SF/buddha_, 13 years ago

The problems with Jolimie don't seem to be related to AGIPAL because I tried removing the 'pal.100' - 'pal.109' files from Jolimie's directory so ScummVM wouldn't change the palette at all and the screen was still black behind the text in Jolimie's start.

So another bug report should be opened for the issue with Jolimie as it's not AGIPAL related.

I'm closing this bug as fixed as it seems AGIPAL support should be working correctly now.

Thanks Robin for the testing!

comment:14 by SF/buddha_, 13 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.