Opened 12 years ago

Closed 10 years ago

Last modified 10 years ago

#3593 closed defect (worksforme)

WINCE: Zak McKracken shuts down when displaying bottom panel

Reported by: SF/leprov Owned by: SF/knakos
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

Version : 0.11.0 (0.10.0 has the same issue)
Language : French (unofficial patch)
Platform : Pocket PC (Windows Mobile 5.0)

Sometimes, the game crashes when i ask the display of the bottom pannel (to save, for example) at the moment I press the hardware button. I didn't manage to identify the exact circumstances when this occurs....Sometimes it crashes, sometimes it doesn't...this never occurs if i hide then display the panel. I always have to wait a moment between both (and changing screens, using objects, etc....). I didn't try and just wait between both operations, doing nothing else that hiding/displaying bar.

So stdout file just says the version isn't officialy supported (of course ^^) and MD5 doesn't match.
stderr file seems to say everything is ok til those messages :

Running on Ozone driver at 480x640 (real 480, 640), using ARM accelerated blitter
SDL: GAPI_WinPAINT NOT IMPLEMENTED

If you need more informations i forgot you can contact me through forum (same nickname)

Ticket imported from: #1878826. Ticket imported from: bugs/3593.

Change History (13)

comment:1 by fingolfin, 12 years ago

Owner: set to SF/knakos
Summary: PPC : Zak McKracken shuts down when displaying bottom panelWINCE: Zak McKracken shuts down when displaying bottom panel

comment:2 by fingolfin, 12 years ago

Does this only happen with Zak, or also with other game?
In particular, you say you are using an unofficial "french" patch -- is that a patch to the game? Or to ScummVM? In either case, it could also be the cause of the problem, so you may want to try with a plain vanilla unmodified version.

comment:3 by SF/knakos, 12 years ago

Also, the 0.11.0 release has significant RAM memory requirements, and I would expect it to fail with random crashes on low memory conditions. F.ex. on Pocket PC *Phones* scummvm is just barely working OK with the amount of free ram available.

So, more details about the vendor, model of your device are needed, plus the scummvm_std[out|err].txt files *could* provide some info in some cases (other than what you mention in your report, which are irrelevant to this bug).

comment:4 by SF/leprov, 12 years ago

so to answer to all of those points :
-the patch is a translate patch of the game.
-The problem doesn't occur on other games. More, loom was patched the same way by the same team, with same tools, and this doesn't occur in loom
-The problem was occuring on 0.10.0 too. More, i have lot of free ram (almost 40MB). My ppc is not a phone so tapi and other shits don't make me going low memory. My device is an acer n321.

about log files :
stdout :
Using configuration file: scummvm.ini
Looking for zak
Trying to start game 'Zak McKracken and the Alien Mindbenders'
Your game version appears to be unknown. Please, report the following
data to the ScummVM team along with name of the game you tried to add
and its version/language/etc.:
SCUMM gameid 'zak', file '00.LFL', MD5 '46583ec0ecc443db614fa465a12cc592'

That is normal cause of the patch

stderr :

SDL: Version $Rev: 41 $ bootstrapping GAPI device
SDL: Device is portrait, OS version 5.1 build 476
SDL: orientation 0
SDL: GAPI_RealizePalette NOT IMPLEMENTED
SDL: Starting video access detection --->
SDL: System 480x640
SDL: Checking for GAPI
SDL: GAPI OK, 240x320, H=2 V=480, 16bpp, landscape false
SDL: Trying Ozone
SDL: Running on Ozone
SDL: Ozone 480x640
SDL: <----- Detection finished. Running on Ozone driver at 480x640 (real 480, 640), using ARM accelerated blitter
SDL: GAPI_WinPAINT NOT IMPLEMENTED

hope this helps.

if you need the patcher, you can get it there :
http://hibernatus34.free.fr/scumm/Zak_TOWNS_FR.exe

comment:5 by SF/knakos, 12 years ago

Status: newpending

comment:6 by SF/knakos, 12 years ago

Well, plain zak fmtowns does not crash over here when cycling the toolbar several times on a VGA device. further, I cannot get the patch to work. it exits with an error like 'invalid files'. can you explain how to patch, or what files it requires etc?

comment:7 by SF/sf-robot, 12 years ago

Status: pendingclosed

comment:8 by SF/sf-robot, 12 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:9 by SF/knakos, 12 years ago

keeping open until I have a chance to check it once more.

comment:10 by SF/knakos, 12 years ago

Priority: normallow
Status: closednew

comment:11 by sev-, 11 years ago

What is the status of this item?

comment:12 by SF/knakos, 10 years ago

Can't check with the patched version. normal fm-towns works ok here on vga.

comment:13 by SF/knakos, 10 years ago

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.