Opened 14 years ago

Last modified 6 months ago

#3594 new defect

SCUMM: MM (NES) - Text artifacts

Reported by: SF/lukasthywalls Owned by:
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Maniac Mansion

Description

I use last SVN ScummVM, with Maniac Mansion NES Version, and Spanish language. I extracted the lfl files with the last scumm_mm_nes.exe

In the "Image 1" can see the "S" letter of other dialog, It stay on the screen until other letter overwrite this section.

I attached the savegame near of this.

Morover, if you got the "S", if you reload the savegame, you can see the "Image 2", with the borders of other room in the actual room.

Ticket imported from: #1879601. Ticket imported from: bugs/3594.

Attachments (9)

(Image1) bug de letra.JPG (140.6 KB ) - added by SF/lukasthywalls 14 years ago.
Image 1
(Image2) bug de letra + carga.JPG (109.9 KB ) - added by SF/lukasthywalls 14 years ago.
Image 2
maniac-nes-es.s04 (7.6 KB ) - added by SF/lukasthywalls 14 years ago.
Savegame near of bug
scummvm-maniac-nes-es-00000_FixedS.png (13.6 KB ) - added by LukasThyWalls 6 months ago.
scummvm-maniac-nes-es-00001_FixedS.png (13.3 KB ) - added by LukasThyWalls 6 months ago.
scummvm-maniac-nes-es-00002_FixedS.png (14.3 KB ) - added by LukasThyWalls 6 months ago.
scummvm-maniac-nes-es-00003_FixedS.png (9.7 KB ) - added by LukasThyWalls 6 months ago.
scummvm-maniac-nes-es-00000_MissingLetter.png (11.8 KB ) - added by LukasThyWalls 6 months ago.
ManiacMansion-Original_MissingLetter.png (123.6 KB ) - added by LukasThyWalls 6 months ago.

Download all attachments as: .zip

Change History (21)

by SF/lukasthywalls, 14 years ago

Attachment: (Image1) bug de letra.JPG added

Image 1

by SF/lukasthywalls, 14 years ago

Image 2

comment:1 by SF/lukasthywalls, 14 years ago

File Added: (Image2) bug de letra + carga.JPG

by SF/lukasthywalls, 14 years ago

Attachment: maniac-nes-es.s04 added

Savegame near of bug

comment:2 by SF/lukasthywalls, 14 years ago

File Added: maniac-nes-es.s04

comment:3 by bluegr, 14 years ago

Summary: "Lost Letter", Refresh screen and text bug maybeMM NES: Text artifacts

comment:4 by fingolfin, 14 years ago

Summary: MM NES: Text artifactsMANIACNES: Text artifacts

comment:5 by sev-, 13 years ago

Owner: set to sev-

comment:6 by sev-, 11 years ago

Resolution: fixed
Status: newclosed

comment:7 by sev-, 11 years ago

Second bug has been fixed for a while, as for the first one, I need steps to reproduce. That is save _before_ wide text is printed and way to print it. You have to create new bugreport since new bugtracker does not allow to attach additional files.

comment:8 by fingolfin, 11 years ago

Resolution: fixed
Status: closednew

comment:9 by fingolfin, 11 years ago

Hu? Of course you can attach multiple files, you just have to click on "Add a file" (I admit the UI SF.net uses here is horrible, but it does work).

comment:10 by sev-, 10 years ago

Owner: sev- removed

comment:11 by raziel-, 13 months ago

Summary: MANIACNES: Text artifactsSCUMM: MM (NES) - Text artifacts

comment:12 by LukasThyWalls, 6 months ago

Wow. A blast from the past.

OG poster here.

I just re-test this in ScummVM 2.3.0git12075-g40a0e09771 (Feb 1 2021 05:23:30), and the second image (maintaining the borders and the letter after load) is not happening anymore, but the first one is still happening. That last "S" is fixed there since it shows in an early dialog until the end (Several screenshots attached).

To test this i used again extract_mm_nes from ScummVM Tools 2.2.0, just in case there are fixes in the extractor.

Also thinking it could be an issue from an older ScummVM version but the save some what still have the issue, i did a fresh start and read the first sign. With that you can see something is wrong because the last letter from the text is missing (HORRIBLEMENT_, when is HORRIBLEMENTE). The original game shows ok (Attached ScummVM and original screenshot). Maybe soon i can reach again the final part to test again but still i didn't do it.

It's seems something how ScummVM clean the borders in the fixed screens as it does in the scrolling screens in the game.

by LukasThyWalls, 6 months ago

by LukasThyWalls, 6 months ago

by LukasThyWalls, 6 months ago

by LukasThyWalls, 6 months ago

by LukasThyWalls, 6 months ago

Note: See TracTickets for help on using tickets.