Opened 12 years ago

Closed 11 years ago

#3576 closed defect (fixed)

LURE: No interaction with Goewin possible

Reported by: raziel- Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: script Cc:
Game: Lure of the Temptress

Description

ScummVM 0.12.0svn (Jan 19 2008 17:49:35)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

another one from cyberix (get an account man) :-)

The attached savegame puts you in Goewin apothecary
with Goewin standing behind the counter

It's not possible to interact with her (right-click)
except "looking" at her.

I don't know if this is intended in the game scripts
or a bug. So, feel free to close if invalid.

Lure of the Temptress (DOS/English)

AmigaOS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1875547. Ticket imported from: bugs/3576.

Attachments (1)

lure.002 (19.5 KB) - added by raziel- 12 years ago.
Apothecary

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by raziel-

Attachment: lure.002 added

Apothecary

comment:1 Changed 12 years ago by dreammaster

Owner: set to dreammaster

comment:2 Changed 12 years ago by dreammaster

Resolution: outdated
Status: newclosed

comment:3 Changed 12 years ago by dreammaster

This is likely because Cyberix is using an out of date savefile. Originally I had Goewin hardcoded so that you always walked to the same position to talk to her, but this didn't work when she wasn't in the apothecary - you'd walk away from her to same position as in the apothecary and then start talking. I did some further analysis of the original game source, and now it behaves like the original - her 'walk to position' gets specially set when she enters the apothecary, and cleared when she leaves it.

All this means that if Cyberix goes back to a savegame from before he freed Goewin, he should now be able to properly talk to her after she returns to the apothecary.

comment:4 Changed 11 years ago by SF/avatraxiom

Actually, I'm experiencing something like this on a 0.11.1 build. The character tries to walk to the talk point and then can't, and gets a little question bubble above his head. I started the game on this build and all my saves are from this build. I used to be able to talk to her--I think it stopped working after I restored a saved game.

comment:5 Changed 11 years ago by dreammaster

Resolution: outdated
Status: closednew

comment:6 Changed 11 years ago by dreammaster

I've been trying to replicate this bug without much luck. But since it's been confirmed that it can happen on a fresh build, I'm re-opening this bug report.. if anyone encounters this problem, could you post a savegame here so I can look into it further.

comment:7 Changed 11 years ago by dreammaster

Resolution: fixed
Status: newclosed

comment:8 Changed 11 years ago by dreammaster

Nevermind. Finally figured out the problem was due to missing data in the savegame. If you still experience the problem, you'll need to either go to a savegame from before you freed Goewin, or wait until Goewin goes for a walk about the village - you can talk to her then, and from then on, even when she's back in the Apothecary.

Note: See TracTickets for help on using tickets.