Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3548 closed defect (fixed)

COMI: Game crashes on difficulty selection screen

Reported by: eriktorbjorn Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Latest SVN snapshot
English version of the game

I thought someone else would file this bug report, since it was mentioned on #scummvm...

The recent Digital iMUSE cleanups seem to have introduced a bad regression. The easiest way to reproduce it is to start the game and select the difficulty level. ScummVM crashes almost immediately:

scummvm: engines/scumm/imuse_digi/dimuse.cpp:257: void Scumm::IMuseDigital::callback(): Assertion `track->stream' failed.

Ticket imported from: #1864932. Ticket imported from: bugs/3548.

Change History (5)

comment:1 by raziel-, 12 years ago

I get a
assertion "track->stream" failed: file "engines/scumm/imuse_digi/dimuse.cpp", line 257
there and on every save game as soon as sound/music was played

comment:2 by eriktorbjorn, 12 years ago

In the case of the difficulty selection screen, I think what happens is that a track (the sound of the knife, I guess) reaches the end of the region. It tries to switch to the next region, which fails (as expected) so the track is flushed. The track's 'stream' is set to 0, but apparently there's still buffered data to play, so it's still 'used'.

The next time IMuseDigital::callback() is called, the track is used, it's sound handle is still active, it's not fading, and it was never 'souStreamIsUsed', so it reaches the assertion that track->stream is non-zero, which fails.

I don't know if it makes any difference, but I'm using compressed sound files.

comment:3 by bluegr, 12 years ago

Also, I'd like to report that #1848399 - "COMI: Speech drops out, causing crash/freeze" seems to be occuring again after these changes
http://sourceforge.net/tracker/index.php?func=detail&aid=1848399&group_id=37116&atid=418820

comment:4 by fingolfin, 12 years ago

Argh. That happens if you code that late at night. Hrmp, sorry, folks.
Anyway, this issue should be fixed now again. If you notice any other odd/weird things and esp. regressions, please report!

comment:5 by fingolfin, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.