Opened 12 years ago

Closed 12 years ago

Last modified 9 months ago

#3538 closed defect (fixed)

AMIGAOS4: Build Process breaks due to regression

Reported by: raziel- Owned by: lordhoto
Priority: normal Component: Port: AmigaOS4
Keywords: Cc:
Game:

Description

With the commit 30004 (i think)
http://scummvm.svn.sourceforge.net/viewvc/scummvm/scummvm/trunk/common/hashmap.h?r1=30004&r2=30003&pathrev=30004

the build process breaks on my system, i get

ppc-amigaos-g++ -Wp,-MMD,"base/.deps/commandLine.d",-MQ,"base/commandLine.o",-MP -Wall -mcrt=newlib -mstrict-align -mcpu=750 -mtune=7400 -Wno-long-long -Wno-multichar -Wno-unknown-pragmas -pedantic -Wpointer-arith -Wcast-qual -Wconversion -Wshadow -Wimplicit -Wundef -Wnon-virtual-dtor -Wno-reorder -Wwrite-strings -fno-rtti -fno-exceptions -fcheck-new -DHAVE_CONFIG_H -DDATA_PATH=\"/usr/local/share/scummvm\" -DSDL_BACKEND -DDISABLE_CRUISE -DDISABLE_DRASCULA -DDISABLE_IGOR -I. -I. -I./engines -I/SDK/local/newlib/include/SDL -D_GNU_SOURCE=1 -c base/commandLine.cpp -o base/commandLine.o
./common/hashmap.h: In constructor 'Common::HashMap<Key, Val, HashFunc, EqualFunc>::Iterator<NodeType>::Iterator(const Common::HashMap<Key, Val, HashFunc, EqualFunc>::Iterator<Common::HashMap<Key, Val, HashFunc, EqualFunc>::Node>&) [with NodeType = const Common::HashMap<Common::String, Common::String, Common::IgnoreCase_Hash, Common::IgnoreCase_EqualTo>::Node, Key = Common::String, Val = Common::String, HashFunc = Common::IgnoreCase_Hash, EqualFunc = Common::IgnoreCase_EqualTo]':
base/commandLine.cpp:741: instantiated from here
./common/hashmap.h:126: error: 'uint Common::HashMap<Common::String, Common::String, Common::IgnoreCase_Hash, Common::IgnoreCase_EqualTo>::Iterator<Common::HashMap<Common::String, Common::String, Common::IgnoreCase_Hash, Common::IgnoreCase_EqualTo>::Node>::_idx' is private
./common/hashmap.h:141: error: within this context
./common/hashmap.h:127: error: 'const Common::HashMap<Common::String, Common::String, Common::IgnoreCase_Hash, Common::IgnoreCase_EqualTo>* Common::HashMap<Common::String, Common::String, Common::IgnoreCase_Hash, Common::IgnoreCase_EqualTo>::Iterator<Common::HashMap<Common::String, Common::String, Common::IgnoreCase_Hash, Common::IgnoreCase_EqualTo>::Node>::_hashmap' is private
./common/hashmap.h:141: error: within this context
gmake: *** [base/commandLine.o] Error 1

AmigaOS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1858824. Ticket imported from: bugs/3538.

Change History (4)

comment:1 Changed 12 years ago by raziel-

Summary: SCUMMVM: Build Process breaks due to regressionAMIGAOS4: Build Process breaks due to regression

comment:2 Changed 12 years ago by lordhoto

Should be fixed now.

comment:3 Changed 12 years ago by lordhoto

Owner: set to lordhoto
Resolution: fixed
Status: newclosed

comment:4 Changed 9 months ago by digitall

Component: Port: AmigaOS4
Note: See TracTickets for help on using tickets.