Opened 12 years ago

Closed 12 years ago

#3506 closed defect (fixed)

FF: Game stops asking the Oracle about the language

Reported by: SF/zoppologo Owned by: Kirben
Priority: low Component: Engine: AGOS
Keywords: Cc:
Game: The Feeble Files

Description

this problem happen whitin the italian version of Feeble Files, in both 0.10 stable version and the last 0.11 svn (12-12-2007) (windows vista).

when i ask the Oracle about Omnianto (at least this is the italian name for the language of the Company), it writes three lines and then stops. On the contrary the audio goes on to the end, but then i cannot do anything. Even if i click at the beginning in order to show the whole text, it stops.

Ticket imported from: #1849432. Ticket imported from: bugs/3506.

Change History (13)

comment:1 by sev-, 12 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by SF/zoppologo, 12 years ago

i'm sorry if i wasn't clear enough:

ScummVM version: both 0.10 and last svn (12-12-2007)
Bug details: when i ask the Oracle about Omnianto (at least this is the italian name for
the language of the Company), it writes three lines and then stops. i must force scummvm to close(there is no need for a savegame to reproduce it)
Language of game: Italian
Version of game: talkie 4CD
Platform: Windows Vista

comment:3 by Kirben, 12 years ago

Summary: FEEBLE: Game stops asking the Oracle about the languageFF: Game stops asking the Oracle about the language

comment:4 by Kirben, 12 years ago

The problem doesn't occur with any other languages, maybe trying extracting/installing main data files from original CD again, in case of corruption.

Unfortunately the Italian language wasn't included on the Macintosh version, it is the only language I don't have for testing.

comment:5 by SF/zoppologo, 12 years ago

reinstalling doesn't help. is there any file i can send to you to solve the problem (or understand if my cds contain corrupted files)?
besides, it is not a big problem, what i have to do is just avoid it :P

comment:6 by fingolfin, 12 years ago

As I understand it, while it would be good to get this fixed, the problem can be avoided. Thus, lowering the priority.

comment:7 by fingolfin, 12 years ago

Priority: normallow

comment:8 by fingolfin, 12 years ago

Kirben, is there anything zoppologo could do to help us analyze the problem?

comment:9 by Kirben, 12 years ago

A dump of all subroutines, might help show where the problem occurs in scripts.

Start ScummVM via command line, with output redirected to a file. ie:
scummvm feeble > feeble_it.txt

Wait for the game to be displayed.
Press 'CTRL u' to dump all subroutines.
Wait a minute or two for output to complete.
Quit ScummVM.

Then compress the 'feeble_it.txt' file, and attach the compressed file, to this bug report.

comment:10 by SF/simsaw, 12 years ago

This bug obviously occurs, because the game's text contains an illegal character with the hex value F8. ScummVM should either print a space or nothing for such an illegal one or nothing (the latter is what I would suggest).

comment:11 by Kirben, 12 years ago

The text of the Oracle uses the hard coded font table, so it is possible that the Italian font table was actually larger. Could you check what happened in the original game?

Attaching the Run95.exe file from original game would be helpful too, so I could double check the size of font table.

comment:12 by Kirben, 12 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:13 by Kirben, 12 years ago

Fixed in ScummVM 0.12.0svn, use the next daily snapshot.

SimSaw confirmed the problem occurred in the original version, and I altered code to ignore invalid characters.

Note: See TracTickets for help on using tickets.