Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3449 closed defect (fixed)

IHNM: Edna's got two hearts but loves to be on the hook

Reported by: (none) Owned by: bluegr
Priority: normal Component: Engine: SAGA
Keywords: script Cc:
Game: I Have No Mouth

Description

Using configuration file: scummvm.ini
ScummVM 0.11.0svn (Nov 6 2007 07:08:26)

Chapter 1 (Gorrister)
When trading Edna's heart with the Jackal for
Gorristers own, one should be able to go back and
[ take Edna off the hook ]... instead the phrase
[ cut Edna's heart out ] is given again, which one can
do to receive a heart but with the symbol of the
"Psychic Profile book" (savegame attached) added to
AND Gorristers own heart vanished from the inventory.

Not to mention this behaviour leaves one stuck at that
state of game

I Have no Mouth and i must Scream (DOS/English)

Amiga OS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1826871. Ticket imported from: bugs/3449.

Attachments (1)

ihnm.s04 (1.2 KB) - added by SF/*anonymous 12 years ago.
See the two books in the inventory

Download all attachments as: .zip

Change History (10)

Changed 12 years ago by SF/*anonymous

Attachment: ihnm.s04 added

See the two books in the inventory

comment:1 Changed 12 years ago by bluegr

This is a script bug, and I think it's not in ScummVM only but in the original as well (but this must be tested).

In any case, as a hint, you are not supposed to kill Edna. Look around the freezer room, there should be something else to give to the jackal instead of Edna's heart...

comment:2 Changed 12 years ago by bluegr

Owner: set to bluegr

comment:3 Changed 12 years ago by bluegr

That's strange, I've tried to duplicate this bug, but I can't. I cut out Edna's heart, gave it to the jackal, and when I go back to the freezer room, I am unable to interact with her at all (i.e. Gorrister says "Edna, now you really are heartless"). What steps did you do to cause this behavior?

comment:4 Changed 12 years ago by (none)

Neither can i?

Well at least i dunno how to reproduce it now.
Henry (iirc) isn't sitting at the bar (i have the whiskey)
but he should to, because i did everything at the same time.

To Find out who murdered whom, talked to the jackal and
Edna and passed hearts around. Maybe the error arised
because Henry showed up where he shouldn't?

I also listened to ALL of the jukebox "music" before

Strange

comment:5 Changed 12 years ago by (none)

OK, got it

Complicated, but works everytime here

First, don't load a save state, play from the beginning

Do everything to get the Zeppelin down to "Gorrister's"

When in the bar, take the whiskey and play all of the
jukebox's entrys, enter the restroom, read all the graffiti
and use the toilet once (not sure if these steps are
necessary, though) ... step out to find Harry.

Get all the information you need to finish the sidequest
(find out your murderer), that is go back to the restroom,
get the magnifier and such. If you did, talk to Harry again
until he's pointing you to the jackal

Meet the jackal, let him point you to the restrooms, enter
the restrooms

Talk to Edna, talk yourself into rage (Why should i trust my
own murderer?) until the option [ Cut Ednas heart out ] will
pop up, USE that option. Now you got Ednas heart but haven't
been to the jackal a second time - Bingo

Back at the jackal, he wants Ednas heart, what a surprise.
Give it, to get your own back, leave to the restrooms

Look at Edna ("Now you are really heartless"), you can't
talk to her as shes obviously dead, but you CAN
"USE KNIFE ON EDNA" followed by a little "jumpy" animation
when Gorrister pops from the background forth in front of
Edna to cut her heart out once again

If you got it you can try to do everything else, but it
won't work anymore as the bug has kicked in

As i mentioned above, it doesn't work on savegames as they
seem to recover the game flags (or the bug hasn't saved them)

comment:6 Changed 12 years ago by bluegr

Ah so if I'm not mistaken, the real problem is with the "Use knife on Edna" action, right?

comment:7 Changed 12 years ago by (none)

That action triggers the wrong behaviour, yes

or to put it another way, one shouldn't be able to use the
knife on Edna again

comment:8 Changed 12 years ago by bluegr

It seems that the script that deals with Edna is buggy in other ways too, i.e. I was able to cut out her heart first, and then when I used the knife with Edna again, Gorrister was incorrectly able to talk to a dead Edna!

The "correct" way of cutting out Edna's heart would be to talk to her, and await for the dialog option that does this. Since it seems that the script associated with Edna and the knife is incorrect, I've disabled this action ("Use knife with Edna"), which avoids the use of the buggy script and fixes this issue - so only the "correct" way can be used now (talk to Edna)

Closing as fixed

comment:9 Changed 12 years ago by bluegr

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.