Opened 17 years ago

Closed 17 years ago

Last modified 13 years ago

#344 closed defect (invalid)

SIMON: Incorrect position/movement

Reported by: SF/madshi Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

In the room directly after using the teleporter you can
make Simon lose his correct position (savegame
attached). I was able to reproduce it this way:

(1) Collect the stone and the branch, then directly talk
to the man. Do NOT try to go to Sordid, also don't try to
do anything with the bell yet.

(2) After the dialog is through, directly try to go to
Sordid. You are not allowed.

(3) Now "use" the bell with the bell. Not sure whether
this step is necessary, but better do it to be sure.

(4) Now "move" the bell. Not sure whether this step is
necessary, but better do it to be sure.

(5) Now try to go as far to the left top as you can. You'll
(hopefully) notice that Simon goes directly "through" the
wodden bar (or however it is called). You can't reach the
original left top position of the room. Also when you
finally correctly make the bell work, during the short
animation Simon is suddenly at the correct position,
after the animation he's back at the wrong position.

The savegame has the wrong position saved.

Ticket imported from: #580976. Ticket imported from: bugs/344.

Attachments (2)

SAVE.002 (3.0 KB ) - added by SF/madshi 17 years ago.
SAVE.001 (3.0 KB ) - added by Kirben 17 years ago.
fiery pits start

Download all attachments as: .zip

Change History (13)

by SF/madshi, 17 years ago

Attachment: SAVE.002 added

comment:1 by SF/madshi, 17 years ago

Newest daily build, Simon1Win, win32, talkie.

comment:2 by Kirben, 17 years ago

By wodden bar, you mean the sign next to the stand ? if yes
than it occurs in the original simon 1 too.
The second problem also occurs in the originsl simon 1 too.
ScummVM save games seem to use same format as original
games, so check it out yourself if you want.

comment:3 by SF/madshi, 17 years ago

With the wooden bar I mean the stand itself. I tried to
reproduce it with the original game, but I don't have a good
savegame. I only have the save game left, where the position
is already wrong, but none, with which I could try to
reproduce the wrong position. Do you have a savegame,
which you could make available for me, so that I can test it
again with the original simon? Thanx! simon@madshi.net

by Kirben, 17 years ago

Attachment: SAVE.001 added

fiery pits start

comment:4 by Kirben, 17 years ago

Could you please provide a screenshot of first problem, with
wooden bar.
I have attached a save game from scummvm for start of firey
pits which can be used in original game too..

comment:5 by SF/madshi, 17 years ago

Thank you for the save game. I'm still able to reproduce the
problem with ScummVM. But I can't reproduce it with the
original Simon exe. Here's a screenshot:

http://madshi.net/simonpos.jpg

This is with a step added between steps (2) and (3) from
above. In this step (2,5) I walked to the top left of the screen.

comment:6 by Kirben, 17 years ago

Owner: set to Kirben
Status: newclosed

comment:7 by Kirben, 17 years ago

I can also easy reproduce this problem in the original game, I
tried with English Simon 1 dos talkie.
Since both problems (Simon walking to far/high left and
Simon jumping around during sequence) occur in the original
game I'm closing this bug report.

comment:8 by Kirben, 17 years ago

Component: Engine: AGOS
Game: Simon the Sorcerer 1
Owner: Kirben removed
Status: closednew

comment:9 by Kirben, 17 years ago

Component: Engine: AGOS
Game: Simon the Sorcerer 2
Owner: set to Kirben
Resolution: invalid
Status: newclosed

comment:10 by fingolfin, 14 years ago

Component: Engine: AGOSEngine: AGI
Game: Simon the Sorcerer 2Space Quest 2

comment:11 by Kirben, 13 years ago

Component: Engine: AGIEngine: AGOS
Game: Space Quest 2Simon the Sorcerer 1
Note: See TracTickets for help on using tickets.