Opened 12 years ago

Closed 10 years ago

Last modified 10 years ago

#3385 closed defect (worksforme)

PS2: THE DIG: Random freezes

Reported by: SF/kungmidas Owned by: sunmax
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

After playing for a couple of hours, the game can freeze seamingly randomly. Memory leakage? It happened to me a few times. Cursor stucks, nothing responds, music hangs repeating the last second.

Unfortunatelly I did not pay to much attention when it happened, but the two of the times I can recall:
1) Going from Nexus down the ramp to the power generator thingy, just when leaving the Nexus scene
2) A few seconds after entering the Nexus.

- ALWAYS after playing for a long time.
- Never during cutscene or conversation.

(The Nexus seams to be a pretty "heavy" scene, in parts of it the framerate drops quite a bit.)

Version 0.9.1 for the PS2. English version of The Dig. PAL PS2, (the last "fat" PS2 version with built in IR eye), running ScummVM and game from hard drive.
Starting ScummVM from uLaunchElf 4.12, started from HD Advance 2.1.

Ticket imported from: #1778166. Ticket imported from: bugs/3385.

Change History (11)

comment:1 by fingolfin, 12 years ago

Owner: set to lavosspawn

comment:2 by fingolfin, 12 years ago

Freeze after playing for a long time sounds like a timer overflow. Does this problem only occur in The Dig, I wonder?

comment:3 by SF/kungmidas, 12 years ago

I should clearify something in my original post: I DID NOT meen that always after playing for a long time, it hangs - I meant every time it hangs, I've been playing for a long time... Sorry for any missunderstanding.

I just dit a little testing. I started the game, and just loaded a save game (from fairly late in the game). I left the game on at one scene for more than 6 hours (definitly longer than I had played the game when it froze), but the didn't freeze.

comment:4 by fingolfin, 12 years ago

Owner: changed from lavosspawn to sunmax

comment:5 by sev-, 11 years ago

Raising priority. This bug is nice to get fixed before the release.

comment:6 by sev-, 11 years ago

Priority: normalhigh

comment:7 by sunmax, 11 years ago

Hi there kungmidas!

I was not able to reproduce it with The DIG,
but I have similar experience once in a while
with COMI when started from CD/DVD.

Two questions:

a) could you try with 0.12.0 and tell me
if the lock disappears or at least its
frequency decreases?

b) I read you start ScummVM from HD,
do you play The DIG from HD too?

Thanks!
-max

comment:8 by SF/kungmidas, 11 years ago

Hi!

I'm terribly sorry, but I'm afraid I'm not able to do so... =(

First, the problem only happens after playing for a very long time (perhaps after an hour or more). It happened less than 5 times when I played through The Dig, and I played for rather long sessions... Hence the poor description of the problem, first times I don't remember any details and the other occurrences were to few to see more similarities than above...

If I could just start the game and leave the machine running, I would, however, as I've said before the problem doesn't occur when doing so...

The Dig data files where put on HD as well. However, more recently, I've noticed that there are problems with freezes running some PS2 games from the HD as well. Maybe it has something to do with HD Advance & uLaunchElf taking some of the memory or something... So basically, the hang might not even be scummvm's "fault".

If I ever get time to play more SCUMM games on the PS2 I will report here accordingly, however right now I don't see that happen any time soon... =/

Best regards

comment:9 by sev-, 11 years ago

Should we close it then, sunmax?

comment:10 by sev-, 10 years ago

Resolution: worksforme
Status: newclosed

comment:11 by sunmax, 10 years ago

I will rather leave it open:

- it's the only known bug left for ScummVM/PS2 ;-)

- it's stochastic and seems to affect only DIG and COMI

- I was able to trigger it with DIG once in 0.13.1
(wasn't able yet to see if it's still in 0.14.0/1.0rc)

- We will need an enhanced ps2 gdb and plenty of time
(unless some testers come out with a deterministic way
to trigger it)

Note: See TracTickets for help on using tickets.