Opened 12 years ago

Closed 9 years ago

Last modified 9 years ago

#3384 closed defect (fixed)

SIMON1: Acorn CD MD5s

Reported by: SF/pwigren Owned by: sev-
Priority: normal Component: Engine: AGOS
Keywords: detection Cc:
Game: Simon the Sorcerer 1

Description

My Acorn CD Simon the Sorcerer finally arrived in my mail :) The game seems to play perfectly, at least the first screens, as it crashes at the same place as my DOS and CD32v versions do (bug 1769644).

However, it isn't detected when I select the directory in the menu, only when I start it with "scummvm -p . simon1"
Running with -d 3 verifies that it detects the correct version: "Found game: simon1 (CD Acorn/English) (26)"

When adding the game with the menu it say this:

Your game version appears to be unknown. Please, report the following
data to the ScummVM team along with name of the game you tried to add
and its version/language/etc.:
"data", "64958b3a38afdcb85da1eeed85169806", 6943110

I'm using ScummVM 0.10.0

Ticket imported from: #1777795. Ticket imported from: bugs/3384.

Change History (6)

comment:1 by SF/pwigren, 12 years ago

I updated to today's SVN (to test another bug) and it won't start the game at all, even with "scummvm -p . simon1".

comment:2 by Kirben, 12 years ago

The failure to detect the Acorn CD version via launcher, is a limitation of the current game detection code. See bug report #1438631 for similar issues.

The recent failure when using command line is a regression, due to the recent game detection changes I expect. The EXECUTE sub directory should be auto added, when starting the Acorn CD or Acorn CD demo version.

In the meantime, just place all data files into a single directory.

comment:3 by Kirben, 12 years ago

Owner: set to sev-

comment:4 by sev-, 9 years ago

Fixed in SVN. Please retest.

comment:5 by sev-, 9 years ago

Resolution: fixed
Status: newclosed

comment:6 by Kirben, 9 years ago

The Acorn CD version (demo and full version) are detected and work fine, when using their original directory structure now.

Note: See TracTickets for help on using tickets.