Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#3313 closed defect (worksforme)

DOTT: Crash when attempting to flush using chronojohn

Reported by: SF/mscdex Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

I'm running Xubuntu 7.04 and ScummVM 0.10.0 (Jun 21 2007 11:52:56). I am trying to play the CD version of DOTT (using uncompressed data files). Everything seems to play fine except when I try to flush something with the chronojohn using any of the characters, at which point it crashes.

The console reports:

Looking for tentacle
Trying to start game 'Day of the Tentacle'
scummvm: backends/saves/compressed/compressed-saves.cpp:217: CompressedOutSaveFile::CompressedOutSaveFile(Common::OutSaveFile*): Assertion `_zlibErr == 0' failed.
Aborted (core dumped)

If it matters, I have version 1.2.3-13ubuntu4 installed of the zlib runtime, which is the latest available from the online repositories. I'd also like to note that I have _disabled_ the automatic game saving in the ScummVM options (from the GUI) in hopes to get rid of this message but it did not help.

Ticket imported from: #1751608. Ticket imported from: bugs/3313.

Change History (15)

comment:1 Changed 12 years ago by SF/mscdex

Summary: Crash when attempting to flush using chronojohnDOTT: Crash when attempting to flush using chronojohn

comment:2 Changed 12 years ago by bluegr

Could you provide a savegame to a spot where this occurs? (i.e. outside a chronojohn, holding an item that can be flushed)

comment:3 Changed 12 years ago by SF/mscdex

I tried saving a game (near a chronojohn, and even right away after the game starts) and it just crashes with the same error. The .c00 and .s01 files that are "saved" are both 0 bytes.

comment:4 Changed 12 years ago by bluegr

Did you compile ScummVM yourself? Have you changed any of the compilation options?

Have you tried reinstalling zlib?

comment:5 Changed 12 years ago by fingolfin

Status: newpending

comment:6 Changed 12 years ago by fingolfin

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:7 Changed 12 years ago by SF/mscdex

Status: pendingnew

comment:8 Changed 12 years ago by SF/mscdex

I am using the Debian package (IIRC, been awhile since I installed it). I tried reinstalling zlib, but still same thing happened.

comment:9 Changed 11 years ago by sev-

What is the status of this item?

comment:10 Changed 11 years ago by sev-

Status: newpending

comment:11 Changed 11 years ago by sev-

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:12 Changed 11 years ago by SF/mscdex

Status: pendingnew

comment:13 Changed 11 years ago by SF/mscdex

I have since updated to Xubuntu Gutsy 7.10 and reinstalled Scummvm 0.10 via the debian package. I first had to manually install the libflac7 package from the feisty repository in order to install however. But I notice it no longer crashes now when using the chronojohn on DOTT. Perhaps it is related only to running 0.10 on feisty?

comment:14 Changed 11 years ago by fingolfin

Closing this, as we can't reproduce the issue and nobody else seems to suffer from it.

comment:15 Changed 11 years ago by fingolfin

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.