Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3291 closed defect (fixed)

KQ3: Lockup when pressing ESC (Amiga version)

Reported by: (none) Owned by: bluegr
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: King's Quest 3

Description

ScummVM 0.11.0svn (Jul 2 2007 12:07:38)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2 ţ

When pressing ESC the pull-down menu should turn up.
(Though the HELP page (F1) says ESC is meant to pause
the game). Anyway the pull down menu doesn't show up,
rather the game is stuck from that point on.
Neither pressing ESC again nor any other key does
anything.
One can quit by closing ScummVM's window, though.

No ScummVM error message at all...

May be related to the HELP key issue mentioned here:
https://sourceforge.net/tracker/?func=detail&atid=418820&aid=1733297&group_id=37116

King's Quest III: To Heir Is Human
(1.01 1986-11-08/Amiga/English)

AmigaOS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1746661. Ticket imported from: bugs/3291.

Change History (5)

comment:1 Changed 12 years ago by bluegr

*Sigh*. Yet another bug which occurs under AmigaOS, but not under Windows (and probably not under *nix, either)

I can't reproduce this. When I press the ESC key in KQ3, the menu appears normally. When I press F1, the help screen appears, as it should

Running ScummVM SVN under Windows Vista 32-bit

comment:2 Changed 12 years ago by (none)

With this version (from the Kings Quest Compilation)
King's Quest III: To Heir Is Human
(2.14 1988-03-15 3.5"/DOS/English)
i neither get the issue.

Maybe it's because the versions differ in more than only
platform changes. Plus the Amiga version is 2 years older
and may have some script differences.

But i think you already tried it with the very same
version?

I'd love to do some more in-depth tests, if you can show
me how to insert debug outputs and where.

comment:3 Changed 12 years ago by bluegr

Ah that sheds some more light. So it's the Amiga version of the game that's having this issue

comment:4 Changed 12 years ago by bluegr

Fixed in the latest SVN

Closing

comment:5 Changed 12 years ago by bluegr

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.