Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3292 closed defect (fixed)

SIMON1: Another crash in dwarf cave

Reported by: hkzlab Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

When in dwarf cave, if i walk down the right stairs and wait a few seconds on the screen with the sleeping dwarf, the game crashes with this error:

scummvm: engines/agos/gfx.cpp:1076: void AGOS::AGOSEngine::animate(uint16, uint16, uint16, int16, int16, uint16, bool): Assertion `READ_BE_UINT16(&((AnimationHeader_Simon *) p)->id) == vgaSpriteId' failed.

Savegame attached.

Ticket imported from: #1747154. Ticket imported from: bugs/3292.

Attachments (1)

simon1.001 (720 bytes ) - added by hkzlab 12 years ago.
Simon1 Dwarf cave

Download all attachments as: .zip

Change History (7)

by hkzlab, 12 years ago

Attachment: simon1.001 added

Simon1 Dwarf cave

comment:1 by Kirben, 12 years ago

Which ScummVM version? which platform?

Which language and version of Simon the Sorcerer 1?

I can't reproduce the issue with English DOS/Windows CD versions.

comment:2 by Kirben, 12 years ago

Owner: set to Kirben

comment:3 by hkzlab, 12 years ago

DOS Floppy english version... and i forgot to say i'm testing it on SVN revision
27881.

comment:4 by hkzlab, 12 years ago

ok, i borrowed the DOS cd version from a friend, and it seems that there are no problems with that, tried both linux and PSP version (always revision 27881).

It seems to be a problem of the floppy version, alas i don't have any other version to test.

comment:5 by Kirben, 12 years ago

This was a regression, and is fixed in ScummVM SVN. Use the next snapshot of ScummVM 0.11.0svn.

comment:6 by Kirben, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.