Opened 12 years ago

Closed 12 years ago

#3288 closed defect (fixed)

SCUMM: Crash when pressing SPACE (Pause)

Reported by: (none) Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Putt-Putt Travels Through Time

Description

ScummVM 0.11.0svn (Jul 1 2007 08:51:56)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

assertion "(pause && _pauseLevel >= 0) || (!pause && _pauseLevel)" failed: file "engines/engine.cpp", line 185

I get this assertion with every single PuttPutt game
plus at least Sam&Max and think it affects all of the
SCUMM based games. (Haven't tested all, though)

Just press SPACE to pause the game regardless at which
point of the game you are.

Updated English(US)

AmigaOS4
gcc version 4.0.2 (AmigaOS build 20051012)

Not sure when this happened first, but it can't be
that long. It wasn't there in the 0.10.0 release.

Ticket imported from: #1746112. Ticket imported from: bugs/3288.

Change History (4)

comment:1 Changed 12 years ago by fingolfin

Works fine over here... Hm, I made a related commit a bit ago, but if that commit fixes it, something else is seriously broken on the Amiga (namely, that fix of mine added a check for g_engine being 0. If that value is 0 for you, i.e. if that change fixes the issue, there is a *serious* problem in your version of ScummVM, and all sorts of things should cause problems).

comment:2 Changed 12 years ago by (none)

I'm not sure if i understand you right.
I just tried a new build from the latest svn and the issue
is still there, so i *think* my build isn't *that* flawed?

comment:3 Changed 12 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:4 Changed 12 years ago by fingolfin

No, it's not. I think I just found the true cause of the problem and fixed it. Thanks for pointing this out.

BTW, don't get me wrong, the "flawed build" was not meant to put down the Amiga port or anything -- I just was kind of scared from the thought that what I initially suspected to be the cause for this crash (which does not occur over here), was *really* the cause -- because that would have been pretty bad, there would have been nothing I could have done about that then :-/.

So I am kinda happy it just was a very stupid mistake on my side which was responsible for this crash, and not yet another compiler bug :-)

Should the bug still be there with rev 27836, please reopen this item.

Note: See TracTickets for help on using tickets.