Opened 12 years ago

Closed 12 years ago

#3256 closed defect (fixed)

Elvira1: Graphic bugs at the end of the game

Reported by: SF/derb00 Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Elvira 1

Description

ScummVM 0.11.0svn (Jun 18 2007 10:09:04) (the latest Win32 build)

It's the english/floppy/dos version

When you make a save game at the very end (only 1 step is left to win the game in my save) and restore it later, the main screen does not get updated. It just stays like it was before loading the save game.

Too, after you complete the game, you see Elvira talking, but her head isn't displayed at the right location.

The save game is named "end". If you load it, the main screen stays the same, but you can see it is loaded because the inventory changes.
From that screen on all you have to do is use the small dagger in the inventory and you see the ending, with Elvira having her head severed.

Ticket imported from: #1738872. Ticket imported from: bugs/3256.

Attachments (1)

elvira1.001 (2.8 KB ) - added by SF/derb00 12 years ago.
save game "end"

Download all attachments as: .zip

Change History (3)

by SF/derb00, 12 years ago

Attachment: elvira1.001 added

save game "end"

comment:1 by Kirben, 12 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:2 by Kirben, 12 years ago

The glitches in the ending sequence, were caused by the code for clearing the effects of fire wall and ice walls always been enabled.

Fixed in ScummVM 0.11.0svn, use the current Windows snapshot.

The blank screen, after loading this particular saved game, seems to be a limitation of the game engine. As the problem occurs in the original game, when I altered and used this saved game too.

Note: See TracTickets for help on using tickets.