Opened 12 years ago

Closed 12 years ago

Last modified 12 months ago

#3257 closed defect (fixed)

PSP: revision 27553 doesn't build

Reported by: hkzlab Owned by: fingolfin
Priority: normal Component: Port: PSP
Keywords: Cc:
Game:

Description

As of revision 27553, psp backend doesn't build anymore.
This is caused by a missing inclusion of a header file in
"osys_psp.h". Adding #include "graphics/scaler.h" to the header fixes the problem, and permit a correct build.
Output of the failing compilation included.

Ticket imported from: #1740241. Ticket imported from: bugs/3257.

Attachments (1)

build.log (586 bytes ) - added by hkzlab 12 years ago.
Failing build log

Download all attachments as: .zip

Change History (7)

by hkzlab, 12 years ago

Attachment: build.log added

Failing build log

comment:1 by fingolfin, 12 years ago

Owner: set to fingolfin
Summary: [PSP] revision 27553 doesn't buildPSP: evision 27553 doesn't build

comment:2 by fingolfin, 12 years ago

graphics/scaler.h sounds wrong / makes no sense. Does it also compile with graphics/surface.h ?

comment:3 by fingolfin, 12 years ago

Summary: PSP: evision 27553 doesn't buildPSP: revision 27553 doesn't build

comment:4 by hkzlab, 12 years ago

Yes, it does compile with the inclusion of surface.h . Probably it was because scaler.h included surface.h that it comiled without problems.
I should have checked more carefully.

comment:5 by fingolfin, 12 years ago

Resolution: fixed
Status: newclosed

comment:6 by digitall, 12 months ago

Component: Port: PSP
Note: See TracTickets for help on using tickets.