Opened 13 years ago

Closed 13 years ago

#3213 closed defect (fixed)

WATER: Unexpected crash at the end of level 15

Reported by: SF/daniel9 Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Water Worries

Description

I experienced the following strange crash:

After finishing level 15 ScummVM crashed with the error: ERROR: (4:2088:0F2D8): o70_startSound invalid case 222

The console didn't tell me much more, so I started ScummVM with -d10 and got back to the last saved game. But after finishing level 15 again, the error did not return. I tried again, without -d10, but it would not crash again. Maybe the exact order in which I collected the kelpseeds was part of the reasons for the crash. I can not play level 15 exactly like the last one. (silly me!)

In the end, this crash may be just a one time fault. Maybe not. I can not reproduce it. I continued to play the game after that saved position & I have already finished level 18 without a problem.

ScummVM 0.10.0SVN 24-5-2007 PPC on a PowerMac G4 running OSX 10.4.9

Ticket imported from: #1727457. Ticket imported from: bugs/3213.

Attachments (1)

Afbeelding 1.png (74.9 KB ) - added by SF/daniel9 13 years ago.
After finishing level 15…

Download all attachments as: .zip

Change History (3)

by SF/daniel9, 13 years ago

Attachment: Afbeelding 1.png added

After finishing level 15...

comment:1 by Kirben, 13 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:2 by Kirben, 13 years ago

The problem is caused by script errors in the original game, I added the extra case to descumm in the past, but not ScummVM.

Fixed in ScummVM SVN, use the next snapshot of ScummVM SVN.

Note: See TracTickets for help on using tickets.