Opened 13 years ago

Closed 12 years ago

Last modified 10 years ago

#3152 closed defect (invalid)

MI2: Error decompressbitmap

Reported by: SF/ino_mart Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Monkey Island 2

Description

In Monky Island II (floppy disk version) in the game mode with all puzzles the error in attached jpg appears.

This error pops up after Wally and Guybrush escaped from the acid pit in the fortress of LeChuck. In the next scene they are in a dark place that seems to be a room full of dynamite. When the dynamite goes on, you see the see (and LeChucks fortress) with an earthquake.

Just behind the explosion (and the moment that Guybrush should be "flying away" to Dinky Island this error appears.

I'm using ScummVM 0.1.9

Ticket imported from: #1704756. Ticket imported from: bugs/3152.

Attachments (2)

error.JPG (33.9 KB ) - added by SF/ino_mart 13 years ago.
Screenshot with error
monkey2.s06 (18.2 KB ) - added by SF/ino_mart 13 years ago.
savegame just before crash

Download all attachments as: .zip

Change History (16)

by SF/ino_mart, 13 years ago

Attachment: error.JPG added

Screenshot with error

comment:1 by bluegr, 13 years ago

Do you mean ScummVM 0.9.1?

And could you attach a savegame?

comment:2 by eriktorbjorn, 13 years ago

I can't reproduce this with my English version of Monkey Island 2. It came on a CD, but I thought it was identical to the floppy version. For reference, my monkey2.000 is 11,135 bytes and my monkey2.001 is 9,080,329 bytes. The MD5 sums are:

3686cf8f89e102ececf4366e1d2c8126 monkey2.000
50993d719990d2e212c50a915f6c50da monkey2.001

comment:3 by fingolfin, 13 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:4 by fingolfin, 13 years ago

Status: newpending
Summary: Error decompressbitmapMI2: Error decompressbitmap

by SF/ino_mart, 13 years ago

Attachment: monkey2.s06 added

savegame just before crash

comment:5 by SF/ino_mart, 13 years ago

I use the English version of Monkey Island II (PC Version floppy disk). This is the first time I run it under scummvm (Windows XP SP2). In past I was able to run it in MS-DOS 6.22, Windows 95 and Windows 98 Sec Ed.

The error also happens with the version of Scummvm I downloaded this morning (http://prdownloads.sourceforge.net/scummvm/scummvm-0.9.1-win32.exe?download)

I've now included the savegame. You only have to do the action "Use matches". The game crashes a few seconds later on my PC.
File Added: monkey2.s06

comment:6 by SF/ino_mart, 13 years ago

Status: pendingnew

comment:7 by eriktorbjorn, 13 years ago

I still can't reproduce it, though I run a different operating system and possibly a different version of the game.

comment:8 by bluegr, 13 years ago

Strange. I can't reproduce it either with version 0.10.0SVN (using your savegame)

Using MI2 English Floppy version as well, under Windows XP SP2

Try the latest SVN version for Windows:
http://scummvm.sourceforge.net/downloads/scummvmwin32.exe

and see if you get this error. If you do, you might have a corrupt file

comment:9 by fingolfin, 12 years ago

Please provide us with the MD5 checksum of all your data files, else we cannot properly process your report.

comment:10 by fingolfin, 12 years ago

Status: newpending

comment:11 by SF/ino_mart, 12 years ago

There is indeed something wrong with the checksum. Reinstalling the game from my original disks did not solve the problem. An old friend of me also bought this game many years ago. Installing the game from his disks did solve the problem.

This incident can be solved (as the reason is a fault somewhere on my original disks)

comment:12 by SF/ino_mart, 12 years ago

Resolution: fixed
Status: pendingnew

comment:13 by fingolfin, 12 years ago

Status: newclosed

comment:14 by Kirben, 10 years ago

Owner: set to fingolfin
Resolution: fixedinvalid
Note: See TracTickets for help on using tickets.